Bug 36481 - ttf-mscorefonts-installer does not install fonts
ttf-mscorefonts-installer does not install fonts
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Felix Botner
Stefan Gohmann
: interim-3
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-06 14:30 CET by Frank Greif
Modified: 2014-11-26 06:54 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Greif 2014-11-06 14:30:55 CET
While installing ttf-mscorefonts-installer, after the downloads, the following messages appear:

grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
grep: /var/lib/msttcorefonts/cabfiles.sha256sums: No such file or directory
sha256sum: standard input: no properly formatted SHA256 checksum lines found
The following fonts failed to install :  andale32.exe arialb32.exe arial32.exe comic32.exe courie32.exe georgi32.exe impact32.exe times32.exe trebuc32.exe verdan32.exe webdin32.exe.
The fonts are NOT installed.
Please run 'dpkg-reconfigure ttf-mscorefonts-installer' to perform the installation again

Seen on UCS4 DC Master and Member, installed from first milestone CD, updated daily with testrepos.

Did not find any related bug/failure report in Debian's package. This could be caused by the fact that the failure is not necessarily noticed in an unattended install: the script doesn't cause the install to fail.
Comment 1 Felix Botner univentionstaff 2014-11-07 11:36:23 CET
Our ttf-mscorefonts-installer patch removed cabfiles.sha256sums from the debian/install file, fixed that.

Installation works now.
Comment 2 Stefan Gohmann univentionstaff 2014-11-10 07:54:48 CET
(In reply to Felix Botner from comment #1)
> Our ttf-mscorefonts-installer patch removed cabfiles.sha256sums from the
> debian/install file, fixed that.
> 
> Installation works now.

Yes, it works.
Comment 3 Stefan Gohmann univentionstaff 2014-11-10 08:00:24 CET
I've also added the bug number to the changelog: r55557
Comment 4 Stefan Gohmann univentionstaff 2014-11-26 06:54:37 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".