Bug 36603 - univention.debug segfault bei reopen()
univention.debug segfault bei reopen()
Status: CLOSED DUPLICATE of bug 37159
Product: UCS
Classification: Unclassified
Component: univention-debug
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-x
Assigned To: Florian Best
Alexander Kramer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-12 14:42 CET by Florian Best
Modified: 2014-12-17 12:54 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
patch (1.01 KB, patch)
2014-11-12 17:03 CET, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-11-12 14:42:38 CET
$ python -c "import univention.debug as ud; ud.init('/var/log/univention/test.log', ud.FLUSH, ud.NO_FUNCTION); ud.reopen()"
Segmentation fault
Comment 1 Florian Best univentionstaff 2014-11-12 17:03:18 CET
Created attachment 6358 [details]
patch

univention_debug_filename was never set and is therefore "\x00" which ends up in segfault when doing strcmp(univention_debug_filename, "stderr").

Attached patch fixes it.
Comment 2 Florian Best univentionstaff 2014-12-15 12:10:09 CET
This was fixed in Bug #37159.

*** This bug has been marked as a duplicate of bug 37159 ***
Comment 3 Florian Best univentionstaff 2014-12-15 14:43:58 CET
Please verify the duplicate.
Comment 4 Florian Best univentionstaff 2014-12-15 14:44:30 CET
The full patch is in svn r56825.
Comment 5 Alexander Kramer univentionstaff 2014-12-16 15:57:05 CET
OK - 37316/17 duplicate
Comment 6 Moritz Muehlenhoff univentionstaff 2014-12-17 12:54:27 CET
http://errata.univention.de/ucs/3.2/251.html