Bug 36617 - Link to UMC of other UCS systems uses HTTP
Link to UMC of other UCS systems uses HTTP
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Florian Best
Stefan Gohmann
: interim-4
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-12 18:51 CET by Janis Meybohm
Modified: 2014-11-26 06:54 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2014-11-12 18:51:19 CET
The links to the UMC of other systems uses HTTP even if the connection to the current UMC is HTTPS
Comment 1 Florian Best univentionstaff 2014-11-12 19:04:12 CET
The host dropdown for single sign on is meant here.
Comment 2 Florian Best univentionstaff 2014-11-12 19:05:28 CET
What browser do you use?
For me it is working with chromium 38.0.2125.101 and Firefox 33.0.1.
Comment 3 Florian Best univentionstaff 2014-11-12 20:31:01 CET
The reason is that cherrypy redirects with 'http://' because cherrypy is behind apache which always does only http requests.

No regression → UCS 4.0-0 errata.
Comment 4 Florian Best univentionstaff 2014-11-13 09:48:23 CET
Apache now gives information about HTTP / HTTPS to the cherrypy umc-webserver.
Changelog entry added.
Comment 5 Stefan Gohmann univentionstaff 2014-11-14 17:09:16 CET
OK, it works now.
Comment 6 Stefan Gohmann univentionstaff 2014-11-26 06:54:21 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".