Bug 36619 - block update if obsolete packages are installed (e.g., univention-windows-installer)
block update if obsolete packages are installed (e.g., univention-windows-ins...
Product: UCS
Classification: Unclassified
Component: Update - Release updates
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Felix Botner
Stefan Gohmann
: interim-4
Depends on:
  Show dependency treegraph
Reported: 2014-11-12 20:45 CET by Felix Botner
Modified: 2014-11-26 06:55 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2014-11-12 20:45:04 CET
block update if obsolete packages are installed (e.g., univention-windows-installer)


Comment 1 Felix Botner univentionstaff 2014-11-13 15:00:57 CET
preup now checks the following packages

      fileutils ipchains kernel-image-2.4.26 lesstif1 libcomerr1-kerberos4kth
      libcurl2 libdb1-compat libdb2 libdb4.0 libdb4.1 libdb4.2++ libdns8
      libgcrypt1 libgd1-xpm libgimp1.2 libgnutls11 libgnutls5 libgnutls7
      libgtkxmhtml1 libidn9 libisc4 libisccfg0 libkdb-1-kerberos4kth libkeynote0
      libkrb-1-kerberos4kth libmm13 libmpeg1 libmysqlclient10 libopencdk4
      libpng10-0 libreadline4 libsensors1 libsoup2.0-0 libtasn1-0 libtiff3g
      libxaw6 libxft1 lynx-ssl symlinks t1lib1 libkrb53 apache-common
      univention-windows-installer-image-linux univention-windows-installer
      univention-windows-installer-image bootsplash-theme-debian
      bootsplash courier-base courier-ssl courier-mta courier-ldap
      courier-imap-ssl courier-imap courier-authdaemon gimp1.2 libg2c0
      gcc-3.2-base gcc-3.3-base gcc-3.4-base gcc-4.1-base cpp-3.2 cpp-3.3
      cpp-4.1 univention-server-installer python2.1 libsasl7 sasl-bin
      libsasl-modules-plain libunivention-chkpwhistory0

if one is installed, the update is blocked (can be disabled with update40/skip/obsolete_packages=true)

added preup for package wamerican-large (replaced by wamerican, wamerican-large is removed )

Update from 1.2-0 to 4.0-0 works for me now.

and added deborphan to maintained in univention-dvd
Comment 2 Stefan Gohmann univentionstaff 2014-11-18 17:33:31 CET
OK, the upgrade was blocked on a very old UCS installation which was updated to UCS 4.0.
Comment 3 Stefan Gohmann univentionstaff 2014-11-26 06:55:50 CET
UCS 4.0-0 has been released:

If this error occurs again, please use "Clone This Bug".