Bug 36822 - Appcenter doesn't run joinscripts after installing e.g. univention-printserver to Memberserver
Appcenter doesn't run joinscripts after installing e.g. univention-printserve...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 3.2
Other Linux
: P5 enhancement (vote)
: UCS 4.0-1-errata
Assigned To: Dirk Wiesenthal
Florian Best
:
: 36348 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-18 15:54 CET by Arvid Requate
Modified: 2015-03-11 15:09 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2014-11-18 15:54:43 CET
When using Appcenter on the DC Master to install e.g. univention-printserver on a Memberserver it doesn't execute the corresponding joinscripts. In this case it's pretty apparent from the fact that after the installation the Memerserver cannot be selected as the system hosting a new printer.

The appcenter should probably ask for join credentials and run the remaining joinscripts on the target host.
Comment 1 Stefan Gohmann univentionstaff 2014-12-02 08:09:15 CET
(In reply to Arvid Requate from comment #0)
> The appcenter should probably ask for join credentials and run the remaining
> joinscripts on the target host.

It should be the default to run the join scripts automatically. We can think about a checkbox which allows to skip the executing of the join scripts.
Comment 2 Alexander Kläser univentionstaff 2014-12-02 11:24:03 CET
(In reply to Arvid Requate from comment #0)
> [...]
> The appcenter should probably ask for join credentials and run the remaining
> joinscripts on the target host.

It should be fine in 99% of all cases to use the credentials of the currently active user session.
Comment 3 Stefan Gohmann univentionstaff 2014-12-03 11:45:43 CET
*** Bug 36348 has been marked as a duplicate of this bug. ***
Comment 4 Dirk Wiesenthal univentionstaff 2015-02-13 01:06:44 CET
Fixed in:
  univention-management-console-module-appcenter 4.1.20-2.314.201502130101

Done by subprocess.Popen('univention-run-joinscripts'). Done even on DC Master (although joinscripts are probably called in postinst) to have a reliable environment.

Joinscript output is sent to the progress bar by reading the last line of join.log.

No new "area" in the progress bar is saved for this. univention-run-joinscripts is run at 100%.
Comment 5 Florian Best univentionstaff 2015-03-04 14:32:24 CET
OK: fix
OK: installation/uninstallation
OK: remote (un/)installation
OK: wrong credentials / non-DomainAdministrator user
~OK: progressbar percentage (I tested the execution time of 6 join scripts, took about 1 minute, so it is OK).
OK: YAML
Comment 6 Moritz Muehlenhoff univentionstaff 2015-03-11 15:09:56 CET
http://errata.univention.de/ucs/4.0/96.html