Bug 37230 - SystemError: E:Problem renaming the file - rename (2: No such file or directory)
SystemError: E:Problem renaming the file - rename (2: No such file or directory)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-2-errata
Assigned To: Florian Best
Dirk Wiesenthal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-08 12:08 CET by Florian Best
Modified: 2015-05-28 16:50 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling, External feedback, Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-12-08 12:08:00 CET
Received Traceback:
Die Ausführung des Kommandos appcenter/query ist fehlgeschlagen:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/__init__.py",
line 176, in _decorated
    return function(self, request, *args, **kwargs)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py",
line 316, in _response
    result = _multi_response(self, request)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py",
line 460, in _response
    return list(function(self, iterator, *nones))
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py",
line 282, in _fake_func
    yield function(self, *args)
  File
"/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/__init__.py",
line 106, in query
    self.package_manager.reopen_cache()
  File "/usr/lib/pymodules/python2.7/univention/lib/package_manager.py", line 648, in
reopen_cache
    self.cache.open()
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 145, in open
    self._cache = apt_pkg.Cache(progress)
SystemError: E:Problem beim Umbenennen der Datei /var/cache/apt/pkgcache.bin.Y6gCxD nach
/var/cache/apt/pkgcache.bin - rename (2: Datei oder Verzeichnis nicht gefunden),
W:Probieren Sie »apt-get update«, um diese Probleme zu korrigieren.

Version:
4.0-0 errata10 (Walle)
Comment 1 Florian Best univentionstaff 2015-02-02 09:22:00 CET
Reported again, 4.0-0 errata0 (Walle).

Traceback:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/management/console/protocol/modserver.py",
line 265, in handle
    self.__handler.init()
  File
"/usr/lib/pymodules/python2.7/univention/management/console/modules/apps/__init__.py",
line 57, in init
    always_noninteractive=True,
  File "/usr/lib/pymodules/python2.7/univention/lib/package_manager.py", line 264, in
__init__
    self.cache = apt.Cache()
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 102, in __init__
    self.open(progress)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 145, in open
    self._cache = apt_pkg.Cache(progress)
SystemError: E:Problem beim Umbenennen der Datei /var/cache/apt/srcpkgcache.bin.954KLM
nach /var/cache/apt/srcpkgcache.bin - rename (2: Datei oder Verzeichnis nicht gefunden),
E:Problem beim Umbenennen der Datei /var/cache/apt/pkgcache.bin.f02tYU nach
/var/cache/apt/pkgcache.bin - rename (2: Datei oder Verzeichnis nicht gefunden), E:Die
Paketliste oder die Statusdatei konnte nicht eingelesen oder ge?ffnet werden.
Comment 2 Florian Best univentionstaff 2015-05-11 11:57:09 CEST
And another one, 4.0-1 errata193 (Walle).

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 266, in handle
    self.__handler.init()
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 86, in init
    lock=False,
  File "%PY2.7%/univention/lib/package_manager.py", line 264, in __init__
    self.cache = apt.Cache()
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 102, in __init__
    self.open(progress)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 145, in open
    self._cache = apt_pkg.Cache(progress)
SystemError: W:Ignoring file '20_ucs-online-component.list.old' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension, W:Ignoring file '20_ucs-online-component.list.old' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension, W:Ignoring file '20_ucs-online-component.list.old' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension, E:Problem renaming the file /var/cache/apt/pkgcache.bin.i85lEb to /var/cache/apt/pkgcache.bin - rename (2: No such file or directory), W:You may want to run apt-get update to correct these problems
Comment 3 Florian Best univentionstaff 2015-05-13 15:12:52 CEST
I could not provoke this error (tried e.g.:)

from univention.lib.package_manager import PackageManager;
from time import sleep;
import subprocess;
subprocess.call('ucr commit /etc/apt/sources.list.d/* &', shell=True);
subprocess.call('apt-get update &', shell=True);
sleep(0.5);
p = PackageManager()

The error message is now replaced by a more meaningful one.

YAML: 2015-05-12-univention-management-console-module-appcenter.yaml
Package: univention-management-console-module-appcenter
Version: 4.1.20-27.354.201505131459
Comment 4 Florian Best univentionstaff 2015-05-19 16:44:27 CEST
Reported again, 4.0-2 errata194 (Walle)

Remark:
Aufruf Appcenter nach Einspielen des letzten Errata Levels

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 266, in handle
    self.__handler.init()
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 86, in init
    lock=False,
  File "%PY2.7%/univention/lib/package_manager.py", line 264, in __init__
    self.cache = apt.Cache()
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 102, in __init__
    self.open(progress)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 145, in open
    self._cache = apt_pkg.Cache(progress)
SystemError: E:Problem beim Umbenennen der Datei /var/cache/apt/pkgcache.bin.Pq0wV7 nach /var/cache/apt/pkgcache.bin - rename (2: Datei oder Verzeichnis nicht gefunden),
W:Probieren Sie >>apt-get update<<, um diese Probleme zu korrigieren.
Comment 5 Florian Best univentionstaff 2015-05-26 09:46:50 CEST
Reported again, 4.0-2 errata194 (Walle)

Remark:
Start App Center
Comment 6 Dirk Wiesenthal univentionstaff 2015-05-27 10:23:12 CEST
OK, cannot reproduce either. Initialization of the apt.Cache is retried 10 times. This feels like a timing issue and should go away by this workaround...
Comment 7 Janek Walkenhorst univentionstaff 2015-05-28 16:50:03 CEST
<http://errata.univention.de/ucs/4.0/203.html>