Bug 37345 - Content scanner could block preup.sh - 4.0
Content scanner could block preup.sh - 4.0
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - Repository administration
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-0-errata
Assigned To: Philipp Hahn
Stefan Gohmann
:
Depends on: 37031
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-15 13:28 CET by Philipp Hahn
Modified: 2015-01-29 11:47 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-12-15 13:28:08 CET
+++ This bug was initially created as a clone of Bug #37031 +++

In a customer environment, dansguardian blocks *.sh *.sh.gpg (which is default) - so the updater fails while preup verification.

We should make this more transparent - the updater should recognize the situation and show hint show to disable content scanner/proxy instead.
Comment 1 Philipp Hahn univentionstaff 2014-12-15 13:35:06 CET
Package: univention-updater
Version: 10.0.51-10.1355.201412151124
Branch: ucs_4.0-0
Scope: errata4.0-0

r56804 | Bug #37031 Up: Detect broken DansGuardian proxy YAML
 2014-12-01-univention-updater.yaml
Comment 2 Stefan Gohmann univentionstaff 2015-01-27 07:11:57 CET
Code review: OK

YAML:OK

Tests: OK
Comment 3 Janek Walkenhorst univentionstaff 2015-01-29 11:47:01 CET
<http://errata.univention.de/ucs/4.0/53.html>