Bug 37564 - updater module shows logfile without content
updater module shows logfile without content
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Software update
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-0-errata
Assigned To: Florian Best
Dirk Wiesenthal
:
: 37713 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-19 09:22 CET by Florian Best
Modified: 2015-02-09 11:02 CET (History)
6 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling, Usability
Max CVSS v3 score:


Attachments
Screenshot (38.78 KB, image/png)
2015-02-06 11:24 CET, Nico Gulden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2015-01-19 09:22:50 CET
From time to time it sometimes happens that the updater module shows a blank logfile page containing only the text "... loading log file ...". This has to do with the UCS 4.0 changes.

There are 2 javascript exceptions
ProgressPage.js:
(startWatching())
  this._pane.set('title', _('Updating...'));

(_process_job_status)
   this._pane.set('title', this._last_job.label);

→ this._pane is undefined

The logfile contains this for the command updater/installer/status:
updater/installer/status returns:
 >> {   '_status_': 'FAILED',
 >>     'command': '/usr/share/univention-updater/univention-updater-umc-dist-upgrade; /usr/share/univention-updater/univention-updater-check',
 >>     'detail': '',
 >>     'elapsed': '0s',
 >>     'job': 'distupgrade',
 >>     'label': 'Package update',
 >>     'lines': 132,
 >>     'logfile': '/var/log/univention/updater.log',
 >>     'purpose': 'Package update',
 >>     'reboot': False,
 >>     'running': False,
 >>     'started': 1420981923,
 >>     'statusfile': '/var/lib/univention-updater/umc-dist-upgrade.status',
 >>     'time': 1420981923}
Comment 1 Florian Best univentionstaff 2015-01-19 09:25:20 CET
Bug #36287 comment 2 with attachment 6279 [details]
Comment 2 Erik Damrose univentionstaff 2015-01-26 13:24:37 CET
Happened to me, too. The update was running and finished correctly, but the UMC module only showed '... Protokolldatei wird geladen ...'. I was not notified after the update process was finished.

switch_progress: Cannot read property 'set' of undefined 

Also happens with 
updater/installer/status returns:
>> {   '_status_': 'RUNNING',
...
Comment 3 Stefan Gohmann univentionstaff 2015-02-06 11:15:27 CET
*** Bug 37713 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Gohmann univentionstaff 2015-02-06 11:16:41 CET
Please have a look. See Bug #37713, it seems to be better reproducible since errata66.
Comment 5 Nico Gulden univentionstaff 2015-02-06 11:23:27 CET
I had this issue two times this week.

1) Started an instance in Amazon EC2, finished the system setup wizard _without_ automatic update at the end. Did the update manually later and then it encountered.

2) Started an instance in Amazon EC2, finished the system setup wizard _with_ automatic update at the end. Continued to work with the system and then Errata Update #78 was published. I updated the system and the issue happened again.

In both cases the updates were installed. I reloaded the management system in the browser and logged in again. A notification confirmed the successful updated and asked me to reboot the system.
Comment 6 Nico Gulden univentionstaff 2015-02-06 11:24:21 CET
Created attachment 6648 [details]
Screenshot

During the update process the management system remains in state of this screenshot. Nothing else happens.
Comment 7 Florian Best univentionstaff 2015-02-06 12:51:01 CET
This happens always when a 'distupgrade' is performed. It exists since UCS 4.0.
Package: univention-updater
Version: 10.0.51-21.1371.201502061242
Branch: ucs_4.0-0
Scope: errata4.0-0
YAML: 2015-02-06-univention-updater.yaml
Fix: svn r57831
Comment 8 Florian Best univentionstaff 2015-02-06 12:56:50 CET
Package: univention-updater
Version: 10.0.52-2.1372.201502061251
Branch: ucs_4.0-0
Scope: ucs4.0-1
Comment 9 Dirk Wiesenthal univentionstaff 2015-02-06 14:03:23 CET
Works.

4.0-1 also okay.
Comment 10 Janek Walkenhorst univentionstaff 2015-02-09 11:02:52 CET
<http://errata.univention.de/ucs/4.0/81.html>