Bug 37701 - postgresql-9.1: Multiple issues (4.0)
postgresql-9.1: Multiple issues (4.0)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.0
Other Linux
: P3 normal (vote)
: UCS 4.0-1-errata
Assigned To: Moritz Muehlenhoff
Janek Walkenhorst
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-06 07:46 CET by Moritz Muehlenhoff
Modified: 2015-03-11 17:16 CET (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2015-02-06 07:46:08 CET
Multiple vulnerabilities have been found in PostgreSQL:

Buffer overflows in "to_char" functions (CVE-2015-0241)
Memory errors in functions in the pgcrypto extension (CVE-2015-0243)
An error in extended protocol message reading (CVE-2015-0244)
Constraint violation errors can cause display of values in columns which the user would not normally have rights to see (CVE-2014-8161)
Comment 1 Moritz Muehlenhoff univentionstaff 2015-03-04 13:06:08 CET
Update has been built. YAML: 2015-03-23-postgresql-9.1.yaml
Comment 2 Janek Walkenhorst univentionstaff 2015-03-09 18:25:29 CET
Tests (amd64): OK
Advisory: OK
Comment 3 Janek Walkenhorst univentionstaff 2015-03-11 17:16:30 CET
<http://errata.univention.de/ucs/4.0/112.html>