Bug 37780 - Fine tuning of UMC design
Fine tuning of UMC design
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-1-errata
Assigned To: Alexander Kläser
Florian Best
:
Depends on:
Blocks: 37892
  Show dependency treegraph
 
Reported: 2015-02-11 18:42 CET by Alexander Kläser
Modified: 2015-02-27 09:52 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Design, Usability
Max CVSS v3 score:


Attachments
Screenshot (47.24 KB, image/png)
2015-02-18 10:13 CET, Florian Best
Details
Screenshot (50.11 KB, image/png)
2015-02-18 10:13 CET, Florian Best
Details
IE Screenshot (67.31 KB, image/png)
2015-02-18 10:27 CET, Florian Best
Details
too much margin Screenshot (128.83 KB, image/png)
2015-02-18 10:34 CET, Florian Best
Details
scrolbar (69.01 KB, image/png)
2015-02-18 11:34 CET, Florian Best
Details
system-setup button label alignment (31.18 KB, image/png)
2015-02-18 11:35 CET, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2015-02-11 18:42:58 CET
This bug is for various design fine tunings that we received over the past time.
Comment 1 Alexander Kläser univentionstaff 2015-02-11 19:37:21 CET
Some changes...

univention-management-console-frontend-theme (0.0.89-2):
Bug #37780:
* add text-overflow=ellipsis to user and host menus in the header
* adjust positioning of "back to overview" button
* soften noisy background pattern image

univention-management-console-frontend (4.1.106-15):
* Bug #37780: The UMC background image has been adjusted.

univention-apache (7.0.16-3):
* Bug #37780: The UCS overview background image has been adjusted.
Comment 2 Alexander Kläser univentionstaff 2015-02-12 18:54:55 CET
More changes...

univention-management-console-module-udm (5.1.25-44):
* Bug #37780: adjust design of search and advanced search button

→ I am not sure whether I should specify a version dependency for the UMC frontend package (which is not mentioned in the list of dependencies).


univention-management-console-frontend (4.1.106-16):
* Bug #37780: the default submit button in the search form has been adjusted
  to only show an icon

univention-management-console-frontend-theme (0.0.89-3):
Bug #37780:
* added CSS rules for the default search button in SearchForm
* some new icons have been added
* margins for the '-' button in MultiInput have been slightly adjusted
Comment 3 Alexander Kläser univentionstaff 2015-02-17 11:28:45 CET
univention-management-console-frontend (4.1.106-19):
Bug #37780:
* add new widget SearchBox with search icon for use in LiveSearchSidebar
* hide inlineLabel of TextBox upon mouse click
* show the last selected category when module search pattern is empty string
* fix intial selected category when favorites are empty

univention-management-console-frontend-theme (0.0.89-4):
* Bug #37780: add CSS rules for SearchBox widget
Comment 4 Alexander Kläser univentionstaff 2015-02-17 11:37:01 CET
univention-management-console-module-udm (5.1.25-46):
* Bug #37780: use inlineLabel in search widget
Comment 5 Johannes Keiser univentionstaff 2015-02-17 15:51:28 CET
Some Changes:

r58159
univention-management-console-module-udm (5.1.25-47)
* Bug 37780: Changed the wording for the 'Back to search' button to 'Back'
    and 'Save changes' to 'Save'

r58160
univention-management-console-frontend-theme (0.0.89-5)
* adjusted styling for the Buttons in the umcModuleHeader
* adjusted styling of the sticky ModuleHeader
* adjusted the color of the heading in the wizard
* long category names now have a line break

r58161
univention-management-console-frontend (4.1.106-20) 
* added close icon for Notifications
* added missing close icon in the top-right corner to certain pop-up dialogs
* fixed display error in the header at small window widths
Comment 6 Johannes Keiser univentionstaff 2015-02-17 16:46:19 CET
Matched the styling for ucs-overview modules with the style from the umc
r58171
univention-apache (7.0.16-4)
* Bug #37780: Adjusted styling for the module items
Comment 7 Alexander Kläser univentionstaff 2015-02-17 17:44:45 CET
r58176
Bug #37780:
* add icons to host and user menus
* enforce a minimum width for module search widget
* respect the UCR variable umc/web/sso/enabled

r58177
univention-management-console-frontend-theme (0.0.89-6):
Bug #37780:
* add icons for user and host menu
* fine tuning of UMC header for small screens
Comment 8 Alexander Kläser univentionstaff 2015-02-17 17:45:21 CET
@Florian: Could you QA all the changes so far tomorrow (18.2.)?
Comment 9 Florian Best univentionstaff 2015-02-18 10:13:36 CET
Created attachment 6686 [details]
Screenshot
Comment 10 Florian Best univentionstaff 2015-02-18 10:13:54 CET
Created attachment 6687 [details]
Screenshot
Comment 11 Florian Best univentionstaff 2015-02-18 10:27:39 CET
Created attachment 6688 [details]
IE Screenshot
Comment 12 Florian Best univentionstaff 2015-02-18 10:34:11 CET
Created attachment 6690 [details]
too much margin Screenshot
Comment 13 Florian Best univentionstaff 2015-02-18 11:34:32 CET
Created attachment 6691 [details]
scrolbar
Comment 14 Florian Best univentionstaff 2015-02-18 11:35:02 CET
Created attachment 6692 [details]
system-setup button label alignment
Comment 15 Florian Best univentionstaff 2015-02-18 11:41:41 CET
(In reply to Alexander Kläser from comment #1)
> univention-management-console-frontend-theme (0.0.89-2):
> Bug #37780:
> * add text-overflow=ellipsis to user and host menus in the header
→ For large devices great, REOPEN: not sure about mobile phones: attachment 6686 [details], attachment 6687 [details]
> * adjust positioning of "back to overview" button
OK
> * soften noisy background pattern image
OK

> univention-management-console-frontend (4.1.106-15):
> * Bug #37780: The UMC background image has been adjusted.
OK
> univention-apache (7.0.16-3):
> * Bug #37780: The UCS overview background image has been adjusted.
OK
(In reply to Alexander Kläser from comment #2)
> univention-management-console-module-udm (5.1.25-44):
> * Bug #37780: adjust design of search and advanced search button
→ very cool!

> → I am not sure whether I should specify a version dependency for the UMC
> frontend package (which is not mentioned in the list of dependencies).
I think you better do, for all the packages: umc-frontend & theme & UDM

> univention-management-console-frontend (4.1.106-16):
> * Bug #37780: the default submit button in the search form has been adjusted
>   to only show an icon
REOPEN: this causes e.g. the quota module to be unable to configure a partition:
domClass.add(button.$refLabel$.domNode, 'umcSearchFormSubmitButton');
Uncaught TypeError: Cannot read property 'domNode' of undefined

> univention-management-console-frontend-theme (0.0.89-3):
> Bug #37780:
> * added CSS rules for the default search button in SearchForm
OK
> * some new icons have been added
OK
> * margins for the '-' button in MultiInput have been slightly adjusted
OK

(In reply to Alexander Kläser from comment #3)
> univention-management-console-frontend (4.1.106-19):
> Bug #37780:
> * add new widget SearchBox with search icon for use in LiveSearchSidebar
OK
> * hide inlineLabel of TextBox upon mouse click
OK
> * show the last selected category when module search pattern is empty string
OK
> * fix intial selected category when favorites are empty
OK

> univention-management-console-frontend-theme (0.0.89-4):
> * Bug #37780: add CSS rules for SearchBox widget
OK

(In reply to Alexander Kläser from comment #4)
> univention-management-console-module-udm (5.1.25-46):
> * Bug #37780: use inlineLabel in search widget
nice!

(In reply to Johannes Keiser from comment #5)
> r58159
> univention-management-console-module-udm (5.1.25-47)
> * Bug 37780: Changed the wording for the 'Back to search' button to 'Back'
>     and 'Save changes' to 'Save'
OK
> r58160
> univention-management-console-frontend-theme (0.0.89-5)
> * adjusted styling for the Buttons in the umcModuleHeader
REOPEN fails in system-setup → attachment 6692 [details]
It also fails if there a multiple layers of buttons

> * adjusted styling of the sticky ModuleHeader
OK
> * adjusted the color of the heading in the wizard
OK

> * long category names now have a line break
OK

> r58161
> univention-management-console-frontend (4.1.106-20) 
> * added close icon for Notifications
OK
> * added missing close icon in the top-right corner to certain pop-up dialogs
exception in the line: deferred.resolve(response);
Reproduce: open the help menu and close it with that close icon
(anonymous function) (dojo.js.uncompressed.js:38738)

> * fixed display error in the header at small window widths

(In reply to Johannes Keiser from comment #6)
> Matched the styling for ucs-overview modules with the style from the umc
> r58171
> univention-apache (7.0.16-4)
> * Bug #37780: Adjusted styling for the module items
~ IMHO this looks strange → at the bottom no padding, icon is very low

(In reply to Alexander Kläser from comment #7)
> r58176
> Bug #37780:
> * add icons to host and user menus
OK, very cool!
> * enforce a minimum width for module search widget
~OK
> * respect the UCR variable umc/web/sso/enabled
~, IE is broken → attachment 6688 [details]

> r58177
> univention-management-console-frontend-theme (0.0.89-6):
> Bug #37780:
> * add icons for user and host menu
OK
> * fine tuning of UMC header for small screens
REOPEN: see at the top
Comment 16 Alexander Kläser univentionstaff 2015-02-18 17:09:12 CET
(In reply to Florian Best from comment #15)
> [...]
> > → I am not sure whether I should specify a version dependency for the UMC
> > frontend package (which is not mentioned in the list of dependencies).
> I think you better do, for all the packages: umc-frontend & theme & UDM

As discussed, I removed the versioned dependencies in order to avoid problems during the update. We prefer minor glitches on the display/with the usability to packages that might be uninstalled (in the worst case) due to broken dependencies.


> > univention-management-console-frontend (4.1.106-16):
> > * Bug #37780: the default submit button in the search form has been adjusted
> >   to only show an icon
> REOPEN: this causes e.g. the quota module to be unable to configure a
> partition:
> domClass.add(button.$refLabel$.domNode, 'umcSearchFormSubmitButton');
> Uncaught TypeError: Cannot read property 'domNode' of undefined

Good catch! I fixed the DOM node handling and adjusted the CSS rules.

r58210
univention-management-console-frontend (4.1.106-24):
* Bug #37780: make node handling more robust in SearchForm

r58211
univention-management-console-frontend-theme (0.0.89-7):
* Bug #37780: adapt style of SearchForm submit button


> [...]
> > * respect the UCR variable umc/web/sso/enabled
> ~, IE is broken → attachment 6688 [details]

Hm, I could not reproduce the problem on IE9 or IE10. As discussed, I reverted the changes anyhow as I misunderstood the term "enabled".

r58220
univention-management-console-frontend (4.1.106-25):
* Bug #37780: reverted changes for umc/web/sso/enabled
Comment 17 Johannes Keiser univentionstaff 2015-02-19 11:54:31 CET
(In reply to Florian Best from comment #15)
> (In reply to Johannes Keiser from comment #5)
> > r58160
> > univention-management-console-frontend-theme (0.0.89-5)
> > * adjusted styling for the Buttons in the umcModuleHeader
> REOPEN fails in system-setup → attachment 6692 [details]
> It also fails if there a multiple layers of buttons

Fixed:
r58234
univention-management-console-frontend (4.1.106-27):
Bug #37780:
* compute label position of module buttons

> > r58161
> > univention-management-console-frontend (4.1.106-20) 
> > * added missing close icon in the top-right corner to certain pop-up dialogs
> exception in the line: deferred.resolve(response);
> Reproduce: open the help menu and close it with that close icon
> (anonymous function) (dojo.js.uncompressed.js:38738)

Fixed:
r58234
univention-management-console-frontend (4.1.106-27):
* fix undefined reference in ConfirmDialog


> (In reply to Johannes Keiser from comment #6)
> > Matched the styling for ucs-overview modules with the style from the umc
> > r58171
> > univention-apache (7.0.16-4)
> > * Bug #37780: Adjusted styling for the module items
> ~ IMHO this looks strange → at the bottom no padding, icon is very low

Fixed:
r58244
univention-management-console-frontend-theme (0.0.89-8):
Bug #37780:
* adjusted module icons position

univention-apache (7.0.16-5)
* Bug #37780: Adjusted module icons position
Comment 18 Florian Best univentionstaff 2015-02-19 12:51:09 CET
(In reply to Florian Best from comment #12)
> Created attachment 6690 [details]
> too much margin Screenshot
still unfixed
Comment 19 Alexander Kläser univentionstaff 2015-02-19 15:34:14 CET
As discussed, we leave the details you pointed out for the next design improvement iteration.
Comment 20 Florian Best univentionstaff 2015-02-19 16:46:10 CET
(In reply to Alexander Kläser from comment #19)
> As discussed, we leave the details you pointed out for the next design
> improvement iteration.
Ok, the rest is cool now, too.
YAML: OK
Comment 21 Johannes Keiser univentionstaff 2015-02-20 13:39:33 CET
I noticed that getMarginBox produces different left, right values for different browser.

r58296
univention-management-console-frontend (4.1.106-29):
* Bug #37780: adjusted computing of label position of module buttons
  to work with firefox.
Comment 22 Moritz Muehlenhoff univentionstaff 2015-02-24 08:22:18 CET
http://errata.univention.de/ucs/4.0/85.html
Comment 23 Moritz Muehlenhoff univentionstaff 2015-02-24 08:23:30 CET
http://errata.univention.de/ucs/4.0/95.html
Comment 24 Moritz Muehlenhoff univentionstaff 2015-02-24 08:24:07 CET
http://errata.univention.de/ucs/4.0/90.html
Comment 25 Moritz Muehlenhoff univentionstaff 2015-02-24 08:25:02 CET
http://errata.univention.de/ucs/4.0/87.html