Bug 37799 - Filter out the groups in which the user is already member
Filter out the groups in which the user is already member
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Users
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-3-errata
Assigned To: Alexander Kramer
Florian Best
:
: 27143 27430 33533 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-16 07:03 CET by Stefan Gohmann
Modified: 2016-10-10 16:21 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): External feedback, Usability
Max CVSS v3 score:


Attachments
user_group.png (68.37 KB, image/png)
2015-02-16 07:03 CET, Stefan Gohmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2015-02-16 07:03:39 CET
Created attachment 6678 [details]
user_group.png

See attached screen shot. If I add a user to a group, I see all groups. Even if the user is already in the group. Theses groups should be filtered out.

Request by a customer.
Comment 1 Alexander Kramer univentionstaff 2015-08-20 09:34:43 CEST
I adapted the MultiObjectSelect widget for udm. Now objects that have already been picked by the user won't appear inside the detailDialog any more.

FYI:
This patch was requested for user groups, but it also effects every MultiObjectSelect widget inside the udm module e.g.:

- user / groups
- user / superior
- groups / General / users & groups
- groups / Advanced settings / Mail & Host member & Member of
- computer / Advanced settings / Groups
- printer / Access control
- some nagios settings as well

@QA: Please check the behavior of every MultiObjectSelect widget inside the udm module.

+ the widget is overwritten inside udm, so this patch won't effect any widget outside the module e.g. settings / language

r 63125:
Successful build
Package: univention-management-console-module-udm
Version: 5.1.25-83.597.201508200849
Branch: ucs_4.0-0
Scope: errata4.0-3

r 63126:
yaml file

r 63129:
Successful build
Package: univention-management-console-module-udm
Version: 6.0.2-2.599.201508200930
Branch: ucs_4.1-0
Scope
Comment 2 Alexander Kramer univentionstaff 2015-08-24 07:47:27 CEST
As requested the patch should be applied to the frontend package
Comment 3 Alexander Kramer univentionstaff 2015-08-24 14:17:33 CEST
ucs 4.0-3 removed changes from udm
r63211

Successful build
Package: univention-management-console-module-udm
Version: 5.1.25-85.602.201508241410
Branch: ucs_4.0-0
Scope: errata4.0-3

r63214 removed yaml entry

ucs 4.1-0 removed changes from udm
r63212

Successful build
Package: univention-management-console-module-udm
Version: 6.0.2-3.601.201508241410
Branch: ucs_4.1-0
Scope:
Comment 4 Alexander Kramer univentionstaff 2015-08-24 15:11:20 CEST
Applied the changes to the frontend package. There we can benefit more of the new behavior.

ucs 4.0-3
r63215

Successful build
Package: univention-management-console-frontend
Version: 4.1.106-89.1099.201508241425
Branch: ucs_4.0-0
Scope: errata4.0-3

r63221 Added yaml file


ucs 4.1-0
r63216

Successful build
Package: univention-management-console-frontend
Version: 5.0.12-3.1100.201508241453
Branch: ucs_4.1-0
Scope:
Comment 5 Florian Best univentionstaff 2015-09-02 12:54:05 CEST
As discussed:
* add a setter for ignoreIds which updates the underlying dialog (it is also public)
* make sure, that "null" does not cause a exception when filtering the search result

The YAML description could be something like:
"""Some widgets are now filtering out values which are already selected and don't present them in a dialog anymore."""

Otherwise it looks fine!
Comment 6 Alexander Kramer univentionstaff 2015-09-03 11:09:28 CEST
(In reply to Florian Best from comment #5)
> As discussed:
> * add a setter for ignoreIds which updates the underlying dialog (it is also
> public)

- renamed ignoreIds to _ignoreIds
- added setIgnoreIdsAttr function

> * make sure, that "null" does not cause a exception when filtering the
> search result

- added if condition for this case
 
> The YAML description could be something like:
> """Some widgets are now filtering out values which are already selected and
> don't present them in a dialog anymore."""

- adapted yaml as suggested

ucs 4.0-3
r 63417 fix and debian/changelog
r 63426 yaml file

Successful build
Package: univention-management-console-frontend
Version: 4.1.106-90.1110.201509030947
Branch: ucs_4.0-0
Scope: errata4.0-3

ucs 4.1-0
r 63418 fix and debian/changelog

Successful build
Package: univention-management-console-frontend
Version: 5.0.17-2.1111.201509031046
Branch: ucs_4.1-0
Scope:
Comment 7 Florian Best univentionstaff 2015-09-09 08:41:51 CEST
Fix works, YAML: OK
Comment 8 Janek Walkenhorst univentionstaff 2015-11-04 17:25:17 CET
<http://errata.software-univention.de/ucs/4.0/353.html>
Comment 9 Florian Best univentionstaff 2016-06-15 10:58:10 CEST
*** Bug 27143 has been marked as a duplicate of this bug. ***
Comment 10 Florian Best univentionstaff 2016-10-10 14:02:10 CEST
*** Bug 33533 has been marked as a duplicate of this bug. ***
Comment 11 Florian Best univentionstaff 2016-10-10 16:21:55 CEST
*** Bug 27430 has been marked as a duplicate of this bug. ***