Bug 37910 - Missing hyphen/dash in univention-run-join-scripts
Missing hyphen/dash in univention-run-join-scripts
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Client management
UCC 2.0
Other Linux
: P5 normal
: UCC 2.0-errata
Assigned To: Moritz Muehlenhoff
Felix Botner
:
: 37911 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-02 10:48 CET by Michael Grandjean
Modified: 2015-08-07 15:34 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grandjean univentionstaff 2015-03-02 10:48:18 CET
This also applies to UCC 2.0

+++ This bug was initially created as a clone of Bug #37909 +++

> 138       if [ -z "$binddn" ]; then
> 139               # Next check is the local ldapi interface
> 140               binddn="$(univention-ssh "$DCPWD" "$DCACCOUNT"@"$ldap_master" \
> 141                       ldapsearch -x LLL -H ldapi:/// "(&(uid=$DCACCOUNT)(objectClass=person))" dn | ldapsearch-decode64 | sed -ne 's|^dn: ||p;s|^DN: ||p')"
> 142       fi

Because there is a '-' missing before 'LLL', ALL DNs are returned and not only the one we are looking for ($DCACCOUNT).
This might let the join fail, produce confusing warnings during join and is probably related to Bug #30222.

This also applies to UCC 2.0. The version in UCS has been fixed with Bug #32005. 
I guess we should regularly adopt the current version from UCS.
Comment 1 Stefan Gohmann univentionstaff 2015-03-11 07:12:31 CET
*** Bug 37911 has been marked as a duplicate of this bug. ***
Comment 2 Moritz Muehlenhoff univentionstaff 2015-03-25 14:54:20 CET
Fixed in revision 59380

YAML: 2015-03-25-univention-ucc-join.yaml
Comment 3 Felix Botner univentionstaff 2015-04-22 13:48:07 CEST
OK - univention-run-join-scripts 
OK - update
OK - YAML
Comment 4 Erik Damrose univentionstaff 2015-08-07 15:34:00 CEST
http://errata.univention.de/ucc/2.0/12.html