Bug 38032 - Select interface
Select interface
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCS Installer
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.1-1
Assigned To: Philipp Hahn
Felix Botner
:
: 39337 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-13 10:12 CET by Philipp Hahn
Modified: 2016-02-16 16:49 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2015-03-13 10:12:41 CET
The Debian Installer automatically selects the first interface for installation, which is problematic, as server hardware often has multiple interfaces.
E.g. our cloud servers have eth[0..3] and usb0 - the last one is selected by default, which make configuration and installing impossible.

<https://help.ubuntu.com/community/Installation/Netboot#Multiple_Network_Interface_Note> has a hint to specify "netcfg/choose_interface=eth1" on the kernel command line.
Comment 1 Philipp Hahn univentionstaff 2015-03-13 12:35:15 CET
This is caused by "=auto in /preseed.cfg

netcfg-common.c
 855     /* If no default was provided, use the first in the list of interfaces. */                                                                                                                                                         
 856     if (! defif && num_interfaces > 0) {
 857         defif = ifs[0];
 858     }
...
 914         /* If the question is not asked, honor preseeded interface name.
 915          * However, if it was preseeded to "auto", or there was no old value,
 916          * leave it set to defif. */
 917         if (!asked && strlen(old_selection) && strcmp(old_selection, "auto") != 0) {                           
 918             debconf_set(client, "netcfg/choose_interface", old_selection);
 919         }

IMHO we should remove the pre-seeding as
- for one interface only that one is still chosen automatically
- in all other cases the user should be asked as everything other is hard understand and to explain

As a work-around "netcfg/choose_interface=eth99" can be appended to the kernel command line in GRUB.
Comment 2 Philipp Hahn univentionstaff 2016-02-03 08:22:25 CET
*** Bug 39337 has been marked as a duplicate of this bug. ***
Comment 3 Philipp Hahn univentionstaff 2016-02-03 11:01:42 CET
Ticket #2016012621000685: Forum-Feedback

(In reply to Philipp Hahn from comment #1)
> As a work-around "netcfg/choose_interface=eth99" can be appended to the
> kernel command line in GRUB.

Does not work as /preseed.cfg from the DVD has a higher priority than kernel-cmdline. This was Debian Bug <http://bugs.debian.org/805291>, which is fixed newer in 'debian-installer/packages/preseed' 1.69 - UCS-4.0 has 1.58.

According to <https://www.debian.org/releases/stable/i386/apbs02.html.en> 'interfaces' is a shortcut for 'netcfg/choose_interface'.
Comment 4 Philipp Hahn univentionstaff 2016-02-10 11:18:02 CET
r67290 | Bug #38032 DVD: Remove auto interface selection
 netcfg/choose_interface=auto has been removed from the file preseed.cfg

Please note that the output of netcfg is rather limited and only displays "Ethernet" with no additional info like "MAC-Address" or "Link-State"

Package: repo-ng
Version: 2.0-256.1493.201602100813
Branch: ucs_3.2-0
Scope: internal

No YAML as repo-ng is internal
Comment 5 Felix Botner univentionstaff 2016-02-15 15:32:07 CET
FAIL - Changelog? i think this is worth mentioning ...

OK - one interface, no interface selection dialog
OK - multiple network interface, interface selection dialog,
     selected interface is configured after setup
Comment 6 Stefan Gohmann univentionstaff 2016-02-16 09:53:06 CET
(In reply to Felix Botner from comment #5)
> FAIL - Changelog? i think this is worth mentioning ...

Done: r67455
Comment 7 Felix Botner univentionstaff 2016-02-16 12:36:05 CET
OK
Comment 8 Stefan Gohmann univentionstaff 2016-02-16 16:49:45 CET
UCS 4.1-1 has been released:
 https://docs.software-univention.de/release-notes-4.1-1-en.html
 https://docs.software-univention.de/release-notes-4.1-1-de.html

If this error occurs again, please use "Clone This Bug".