Bug 38132 - Improve license import work flow
Improve license import work flow
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Domain management (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-1-errata
Assigned To: Alexander Kläser
Alexander Kramer
:
: 25262 36838 37954 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-25 15:56 CET by Alexander Kläser
Modified: 2015-04-08 12:35 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2015-03-25 15:56:45 CET
During our usability tests, we noted that the users had problems to import a new license after a UCS appliance had been configured:

* Users requested 2-3 license, as it was not obvious that a license had already been sent to their email address during the setup process.

* When importing a license, a UMC reload is executed. If the user is in the process of installing an app, this interrupts the installation process and leads to a situation where the user might not be sure whether or not the installation has been executed. In any case, he will need to navigate to the app again in order to install it.

* It is expected that a confirmation dialogue is prompted when the email for activating UCS has been sent.
Comment 1 Alexander Kläser univentionstaff 2015-03-25 15:57:06 CET
*** Bug 36838 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Kläser univentionstaff 2015-03-25 15:57:16 CET
*** Bug 37954 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2015-03-25 15:58:50 CET
*** Bug 25262 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Kläser univentionstaff 2015-03-25 16:13:19 CET
(In reply to Alexander Kläser from comment #0)
> [...]
> * When importing a license, a UMC reload is executed. If the user is in the
> process of installing an app, this interrupts the installation process and
> leads to a situation where the user might not be sure whether or not the
> installation has been executed. In any case, he will need to navigate to the
> app again in order to install it.

After the license import, the session is now updated automatically, as well... similary to installing an app (via the SSO mechanism).

(In reply to Alexander Kläser from comment #1)
> *** Bug 36838 has been marked as a duplicate of this bug. ***

Fixed.

(In reply to Alexander Kläser from comment #2)
> *** Bug 37954 has been marked as a duplicate of this bug. ***

Fixed.

(In reply to Florian Best from comment #3)
> *** Bug 25262 has been marked as a duplicate of this bug. ***

Should be fine.

univention-management-console-module-udm (5.1.25-59) [r59429]:
Bug #38132:
* renew UMC session via SSO after importing a new license
* prompt error message if text field is empty
* add CSS class umcLargeDialog to the LicenseImportDialog
Comment 5 Alexander Kläser univentionstaff 2015-03-26 17:40:50 CET
(In reply to Alexander Kläser from comment #0)
> [...]
> 
> * Users requested 2-3 license, as it was not obvious that a license had
> already been sent to their email address during the setup process.
> 
> [...]
> 
> * It is expected that a confirmation dialogue is prompted when the email for
> activating UCS has been sent.

I added an extra page into the startup wizard for importing the license file. This page starts with the words "You have got mail!" in order to ask the user to have look into his mailbox. Two scenarios are respected: no license key has been requested and a license key has already been sent during the setup process.

univention-management-console-frontend (4.1.106-46) [r59460]:
* Bug #38132: added page to startup dialogue for importing the license file
Comment 6 Alexander Kläser univentionstaff 2015-03-26 19:11:12 CET
I improved the tracking of actions in the startup wizard (+ added UCS version / number of tabs as custom information).

univention-management-console-frontend (4.1.106-47) [r59462]:
* Bug #38132: improve tracking of UMC actions
Comment 7 Alexander Kläser univentionstaff 2015-03-27 12:39:45 CET
Just for the records... after updating the UMC session via SSO (in the license dialogue and in the startup wizard), the license menu entries (in the user menu) are not updated, i.e., the option "Activation of UCS" is still visible. However, I think that this does not pose a real problem.
Comment 8 Alexander Kläser univentionstaff 2015-03-27 17:13:20 CET
I improved the activation dialogue with a small wizard of three pages. The first two are the same pages that are also used in the startup wizard. This dialogue is also called from within the App Center, i.e., when importing a license from there, the handling is also improved significantly now :) . (The only downside of my changes is that some code/logic has been a bit duplicated.)

univention-management-console-module-udm (5.1.25-60):
* Bug #38132: use small wizard for license activation dialogue

univention-management-console-frontend (4.1.106-48):
* Bug #38132: use small wizard for license activation dialogue
Comment 9 Alexander Kläser univentionstaff 2015-03-27 17:20:19 CET
YAML files have been added, package versions have not yet been updated [r59478].
Comment 10 Alexander Kramer univentionstaff 2015-03-31 13:02:08 CEST
found two missing translations for the german version:

(1) ucs activation:
next to the input field for the mail address the button 'Send licence' have to be translated

(2) the success msg that appears after activating ucs from the appcenter is only available in english.
Comment 11 Alexander Kläser univentionstaff 2015-03-31 17:58:39 CEST
(In reply to Alexander Kramer from comment #10)
> found two missing translations for the german version:
> 
> (1) ucs activation:
> next to the input field for the mail address the button 'Send licence' have
> to be translated
> 
> (2) the success msg that appears after activating ucs from the appcenter is
> only available in english.

True! There was a duplicated entry in the de.po file. Fixed.

r59519 | Bug #38132: added missing translations
Comment 12 Alexander Kramer univentionstaff 2015-04-02 09:38:28 CEST
As discussed please change the following translation:

Sie können nun eine gültige E-Mail-Adresse angeben, um das UCS-System für die Verwendung des App Centers freizuschalten. Im nächsten Schritt können Sie die Lizenzdatei hochladen, die an Ihre E-Mail-Adresse ...

- old: zugeschickt wird
- new: gessendet wird.
Comment 13 Alexander Kläser univentionstaff 2015-04-02 13:05:02 CEST
(In reply to Alexander Kramer from comment #12)
> As discussed please change the following translation:
> 
> Sie können nun eine gültige E-Mail-Adresse angeben, um das UCS-System für
> die Verwendung des App Centers freizuschalten. Im nächsten Schritt können
> Sie die Lizenzdatei hochladen, die an Ihre E-Mail-Adresse ...
> 
> - old: zugeschickt wird
> - new: gessendet wird.

Fixed. Package is building.

r59585 | Bug #38132: fixed typo
Comment 14 Alexander Kramer univentionstaff 2015-04-02 14:17:06 CEST
univention-management-console-module-udm
OK - YAML
OK - debian/changelog


univention-management-console-frontend
OK - YAML
OK - debian/changelog

OK - FIXED License information dialogue is too narrow
OK - FIXED prevent import of empty license in text field
OK - FIXED Kleinere Anpassungen bei Import von Lizenzen

OK - extra pages into the startup wizard for importing the license file
-- for both cases: (no) mail during system setup

OK - improved the tracking of actions in the startup wizard

OK - small wizard in appcenter

OK - FIXED missing translations and typo
Comment 15 Janek Walkenhorst univentionstaff 2015-04-08 12:35:35 CEST
<http://errata.univention.de/ucs/4.0/144.html>
Comment 16 Janek Walkenhorst univentionstaff 2015-04-08 12:35:50 CEST
<http://errata.univention.de/ucs/4.0/145.html>