Bug 38179 - Firefox: Security issues from 31.6 (4.0)
Firefox: Security issues from 31.6 (4.0)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-1-errata
Assigned To: Janek Walkenhorst
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-31 22:45 CEST by Arvid Requate
Modified: 2015-05-07 17:38 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Security
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2015-03-31 22:45:45 CEST
Same-origin bypass through anchor navigation (CVE-2015-0801)

Potential XSRF affecting sendBeacon() requests (CORS requests should not follow 30x redirections after prefligh) (CVE-2015-0807)

Use-after-free when using the Fluendo MP3 GStreamer plugin (CVE-2015-0813)

Memory safety bugs (CVE-2015-0815)

resource:// documents can load privileged pages (CVE-2015-0816)
Comment 1 Arvid Requate univentionstaff 2015-04-02 19:27:26 CEST
Two more have been fixed in 31.5.2 and 31.5.3:

* Reading and writing of memory allowing for arbitary code execution on the local system (Pwn2Own asm.js exploit) (CVE-2015-0817)
* Run arbitrary scripts in a privileged context (Same-origin bypass via SVG hash navigation) (CVE-2015-0818)
Comment 2 Janek Walkenhorst univentionstaff 2015-04-13 19:02:16 CEST
Advisory: 2015-04-13-firefox-{de,en}.yaml
Tests (i386): OK
Comment 3 Arvid Requate univentionstaff 2015-05-04 15:41:07 CEST
Verified:
* Upstream ESR version imported and built in errata4.0-1
* Package update works, german and english versions tested.
* Advisories Ok.