Bug 38213 - Resync with upstream iTALC
Resync with upstream iTALC
Status: CLOSED FIXED
Product: UCS@school
Classification: Unclassified
Component: iTALC
UCS@school 4.0
Other Linux
: P5 normal (vote)
: UCS@school 4.1 R2 vXXX
Assigned To: Florian Best
Sönke Schwardt-Krummrich
: interim-2
: 40501 (view as bug list)
Depends on: 39593
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-08 12:10 CEST by Sönke Schwardt-Krummrich
Modified: 2016-11-10 16:00 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.257
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2015-04-08 12:10:30 CEST
We should resync our iTALC with the upstream version. There is at least one interesting commit:

https://github.com/iTALC/italc/commit/cb7ab2eb9b3a669c72f29dabba4f5f60234a1ac7
"""discard output from slaves when not in debug mode

The demo slave generates some output via rfbLog. If no one reads the
output channel, eventually the buffer fills and write() blocks, causing
the demo server to hang. This fixes that by sending slave output to
/dev/null when not forwarding it."""
Comment 1 Florian Best univentionstaff 2016-01-18 17:54:02 CET
iTalc 2.0-2 has been integrated. Shall we update to the git HEAD?

patches/002_thread-wait-for-termination.patch has been replaced by https://github.com/iTALC/italc/commit/0f3334f87acf3bd1e0802e75f53e17c8c4d8169d

patches/009_fix_install.patch has been replaces by https://github.com/iTALC/italc/commit/2dbe5f1902bc5cbf46987ea4bfa459aeb3db623a

Btw: we could use the official debian package, shall I import it from e.g. sid and drop our own?

italc (2:2.0.25-3):
r66855 | Bug #38213: Add build dependency libpng12-dev
r66854 | Bug #38213: update to iTalc 2.0-2
r66853 | Bug #38213: update to iTalc 2.0-2
Comment 2 Florian Best univentionstaff 2016-01-19 15:13:50 CET
r66891 | Bug #38213: integrate upstream patches
Comment 3 Florian Best univentionstaff 2016-01-26 14:54:47 CET
The server side iTALC code has been rebased to iTALC 2.0.2 plus some of the commits in the github HEAD.

italc (2:2.0.25-5):
r66971 | Bug #38213: fail if applying patches goes wrong
r66891 | Bug #38213: integrate upstream patches
r66855 | Bug #38213: Add build dependency libpng12-dev
r66854 | Bug #38213: update to iTalc 2.0-2
r66853 | Bug #38213: update to iTalc 2.0-2
Comment 4 Florian Best univentionstaff 2016-07-04 15:56:29 CEST
*** Bug 40501 has been marked as a duplicate of this bug. ***
Comment 5 Florian Best univentionstaff 2016-07-04 16:26:10 CEST
All changes in 4.1 have been reverted and were automatically merged to 4.1R2
when creating the branch.
Comment 6 Florian Best univentionstaff 2016-07-04 16:29:32 CEST
The presentation mode is not working.
https://github.com/iTALC/italc/issues/9
Comment 7 Florian Best univentionstaff 2016-07-08 18:23:25 CEST
All latest changes have been integrated. Presentation mode is working.
Successful build
Package: italc
Version: 2:2.0.25-7.88.201607081747
Branch: ucs_4.1-0
Scope: ucs-school-4.1r2
Comment 8 Florian Best univentionstaff 2016-10-17 11:08:37 CEST
Rebase to the latest changes from github.
Comment 9 Florian Best univentionstaff 2016-10-17 12:52:37 CEST
italc (2:2.0.25-8):
r73276 | Bug #38213: rebase to latest upstream changes
Comment 10 Florian Best univentionstaff 2016-10-17 13:03:31 CEST
build failed due to non-qt4 compatibility in qt-4 branch (https://github.com/iTALC/italc/issues/48).
Comment 11 Florian Best univentionstaff 2016-10-21 16:57:21 CEST
Added a fix for this.

italc (2:2.0.25-9):
r73466 | Bug #38213: Fix QT4 issue
Comment 12 Florian Best univentionstaff 2016-10-25 13:37:05 CEST
ucs-school-italc (10.0.0-3):
r73544 | Bug #38213: implement API Change in displayTextMessage()
r73542 | Bug #38213: implement API Change in displayTextMessage()
r70918 | Bug #38213: rebuild package

ucs-school-umc-computerroom (8.0.7-1):
r73543 | Bug #38213: autopep8
r73542 | Bug #38213: implement API Change in displayTextMessage()
Comment 13 Daniel Tröder univentionstaff 2016-10-25 14:41:29 CEST
OK:
- italc code was updated
- build (qt) fixed
- works correctly together with umc-computerroom (lock, logout, preview, honor ucsschool/umc/computerroom/hide_screenshots/…)
- display of users names with special characters (umlauts) is fixed
Comment 14 Sönke Schwardt-Krummrich univentionstaff 2016-11-09 14:23:49 CET
ucs-school-italc cannot be build on amd64
Comment 15 Sönke Schwardt-Krummrich univentionstaff 2016-11-09 14:30:19 CET
(In reply to Sönke Schwardt-Krummrich from comment #14)
> ucs-school-italc cannot be build on amd64

Cannot be built because italc has not been built for amd64.
Comment 16 Florian Best univentionstaff 2016-11-09 15:55:29 CET
Rebuild both packages for both architectures:
italc 2:2.0.25-11.94.201611091451
ucs-school-italc 10.0.0-3.57.201611091459

I tested all the basic functionality again including presentation mode as teacher/student, sending commands, sending messages.
Comment 17 Sönke Schwardt-Krummrich univentionstaff 2016-11-10 12:02:25 CET
OK: updated amd64 UCS@school system to newest packages
OK: functional test
OK: both packages built for amd64 and i386
OK: advisories
Comment 18 Sönke Schwardt-Krummrich univentionstaff 2016-11-10 16:00:48 CET
UCS@school 4.1 R2 v7 has been released.

http://docs.software-univention.de/changelog-ucsschool-4.1R2v7-de.html

If this error occurs again, please clone this bug.