Bug 38225 - [IE11] Module buttons not visible using https
[IE11] Module buttons not visible using https
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-1-errata
Assigned To: Alexander Kläser
Alexander Kramer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-10 08:38 CEST by Alexander Kläser
Modified: 2015-04-21 09:16 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Browser compatibility, Design, Usability
Max CVSS v3 score:


Attachments
Screenshot of missing module buttons in IE11 (120.04 KB, image/png)
2015-04-10 08:38 CEST, Alexander Kläser
Details
bug with defined background-size (208.04 KB, image/png)
2015-04-13 14:13 CEST, Alexander Kramer
Details
ie still loads svg instead of png (63.09 KB, image/png)
2015-04-15 09:06 CEST, Alexander Kramer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2015-04-10 08:38:40 CEST
Created attachment 6815 [details]
Screenshot of missing module buttons in IE11

See screenshot... this display error does not seem happen when using http. On IE10, the module buttons seem to be fine.
Comment 1 Alexander Kläser univentionstaff 2015-04-10 10:12:29 CEST
Maybe related to the following bug:
> https://connect.microsoft.com/IE/feedback/details/794664/svg-display-issues-with-ie-11

My Windows 8.1 forced me to update the system (well, it just installed updates and rebooted), now it seems that I cannot reproduce the problem anymore.
Comment 2 Alexander Kläser univentionstaff 2015-04-10 11:14:29 CEST
Should still be reproducible on IE 11.0.9600.17691 with Win7.
I saw it with IE 11.0.9600.16663 on Win8(.1?).
Comment 3 Alexander Kläser univentionstaff 2015-04-10 19:00:30 CEST
(In reply to Alexander Kläser from comment #2)
> Should still be reproducible on IE 11.0.9600.17691 with Win7.
> I saw it with IE 11.0.9600.16663 on Win8(.1?).

My best results for reproducing the error (not every time, though) were the following steps on IE 11.0.9600.17031 using Win 8.1 (the instance stefan_Win8-88.1). Install univention-demo-configuration as well as an unlimited license and set the start page in IE to about:blank. If think that I understood that the error is only visible, when using the native VNC viewer (ucs-kt-view), not the browser based one. I think, as well, that the VNC window should be scaled down a bit.

Then perform the following steps:
* Open IE
* Clear the browser cache (the first 4 checkboxes only)
* Leave the note that cache was cleared visible
* Navigate to http://server
* Choose the UMC link
* Choose the link to the HTTPS version (+ confirm security exception)
* Clear the browser cache again (the first 4 checkboxes only)
* Login
* Open the users module
Comment 4 Alexander Kläser univentionstaff 2015-04-10 19:01:26 CEST
(In reply to Alexander Kläser from comment #3)
> [...]
> Then perform the following steps:
> * Open IE
> * Clear the browser cache (the first 4 checkboxes only)
> * Leave the note that cache was cleared visible
> * Navigate to http://server
> * Choose the UMC link
> * Choose the link to the HTTPS version (+ confirm security exception)
> * Clear the browser cache again (the first 4 checkboxes only)

Leave the confirmation here visible, as well.
Comment 5 Alexander Kläser univentionstaff 2015-04-10 19:04:05 CEST
(In reply to Alexander Kläser from comment #1)
> Maybe related to the following bug:
> > https://connect.microsoft.com/IE/feedback/details/794664/svg-display-issues-with-ie-11
> 
> My Windows 8.1 forced me to update the system (well, it just installed
> updates and rebooted), now it seems that I cannot reproduce the problem
> anymore.

The following change could do it... I am optimistic and could verify it in a first attempt. I was an inspired from a comment on the cited linked above.

r59712 | Bug #38225: force bg size for icons to avoid display problems with IE11
Comment 6 Alexander Kläser univentionstaff 2015-04-10 19:05:09 CEST
YAML file is missing...
Comment 7 Alexander Kläser univentionstaff 2015-04-10 19:06:00 CEST
Package is building...
Comment 8 Alexander Kramer univentionstaff 2015-04-13 14:13:47 CEST
Created attachment 6820 [details]
bug with defined background-size
Comment 9 Alexander Kramer univentionstaff 2015-04-13 14:15:00 CEST
As discussed, I was able to reproduce the bug with the fix.

FYI: Size of my VNC Windows: 987x650
Comment 10 Alexander Kläser univentionstaff 2015-04-14 12:52:56 CEST
I included an automatic conversion from SVG to PNG for the icon files and added special rules for IE.

I also needed to update the Dojo toolkit as IE11 is only correctly detect from Dojo 1.10.4 onwards (for user agent specific

https://bugs.dojotoolkit.org/ticket/17927

r59777 | Bug #38225: use PNG image for background icons in IE
r59776 | Bug #38225: update Dojo version to 1.10.4
r59775 | Bug #38225: update Dojo version to 1.10.4

... packages are building.
Comment 11 Alexander Kläser univentionstaff 2015-04-14 13:01:12 CEST
(In reply to Alexander Kläser from comment #10)
> [...]
> ... packages are building.

... and done.

r59780 | Bug #38225: adjusted package version in YAML file
Comment 12 Alexander Kramer univentionstaff 2015-04-15 09:06:10 CEST
Created attachment 6822 [details]
ie still loads svg instead of png

I made a version bump for the frontend package:
4.1.106-53.1034.201504141458

But I am afraid that I can still reproduce the bug. as you can see in the picture the IE is loading the svg instead of the png.
Comment 13 Alexander Kramer univentionstaff 2015-04-15 09:08:02 CEST
installed packages on my vm:

univention-management-console-frontend: 4.1.106-53.1034.201504141458 
univention-management-console-frontend-theme: 0.0.89-13.84.201504141249
Comment 14 Alexander Kläser univentionstaff 2015-04-15 12:09:03 CEST
(In reply to Alexander Kramer from comment #12)
> Created attachment 6822 [details]
> ie still loads svg instead of png
> 
> I made a version bump for the frontend package:
> 4.1.106-53.1034.201504141458
> 
> But I am afraid that I can still reproduce the bug. as you can see in the
> picture the IE is loading the svg instead of the png.

True, as the patch was tagged for 1.10.4 on github, I thought it would be included in 1.10.4. I imported the patch manually in our univention-dojo package.

r59820 | Bug #38225: import patch for sniffing IE11
Comment 15 Alexander Kläser univentionstaff 2015-04-15 12:37:29 CEST
... build is through.

r59824 | Bug #38225: adjusted package versions in YAML files
Comment 16 Alexander Kläser univentionstaff 2015-04-15 17:00:14 CEST
(In reply to Alexander Kläser from comment #14)
> True, as the patch was tagged for 1.10.4 on github, I thought it would be
> included in 1.10.4. I imported the patch manually in our univention-dojo
> package.
> 
> r59820 | Bug #38225: import patch for sniffing IE11

Wrong again, in fact, IE11 follows the web standards and does not behave like an IE anymore. Therefore, feature detection fails in the standard way. See also:

  https://forge.univention.org/bugzilla/show_bug.cgi?id=33990
  http://www.nczonline.net/blog/2013/07/02/internet-explorer-11-dont-call-me-ie/

I removed the patch for dojo/sniff and added some lines to dojo/uacss to add the extra CSS classes dj_trident* for IE11+. Accordingly I adjusted the icon rules in the theme package.

r59837 | Bug #38225: use CSS class dj_trident for IE11+
Comment 17 Alexander Kläser univentionstaff 2015-04-15 19:22:42 CEST
Packages are built.

r59844 | Bug #38225: adjusted YAML files + package versions
Comment 18 Alexander Kläser univentionstaff 2015-04-16 10:26:07 CEST
Oops, I forgot to rebuild the theme package. Done.

r59854 | Bug #38225: adjusted package version

BTW, the dojo team committed a patch that is identical to our patch here:

https://bugs.dojotoolkit.org/ticket/17927#comment:3
Comment 19 Alexander Kramer univentionstaff 2015-04-16 12:07:14 CEST
OK - IE 11 loads png instead of svg

univention-management-console-frontend-theme
OK - debian/changelog
OK - yaml

univention-dojo
OK - debian/changelog
OK - yaml - adpated fix r59863
Comment 20 Alexander Kläser univentionstaff 2015-04-16 13:02:18 CEST
As discussed, I added the bug number into the YAML file for UMC-Frontend package, as well, as there is an indirect (build) dependency to the changes in univention-dojo.

r59873 | Bug #38225: include bug number in umc-frontend package