Bug 38539 - Unconfigured system when using the text based installer
Unconfigured system when using the text based installer
Status: NEW
Product: UCS Test
Classification: Unclassified
Component: UMC
Other Linux
: P5 normal (vote)
: ---
Assigned To: UMC maintainers
Depends on: 38382
  Show dependency treegraph
Reported: 2015-05-13 20:02 CEST by Alexander Kläser
Modified: 2016-10-05 20:19 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional): Error handling, External feedback, Troubleshooting
Max CVSS v3 score:


Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2015-05-13 20:02:39 CEST
It would be helpful to extend our jenkins tests configuration files to include various locale settings (especially en_GB, de_AT, etc.). I tried to inject some output to setup-join.sh by adding the following lines just before the call to 05_role/10role:
-------------------- 8< -------------------- 
eval "$(univention-config-registry shell)"
echo "### locale=$locale"
echo "### locale/default=$locale_default"
echo "### LANG=$LANG"
echo "### LC_ALL=$LC_ALL"
-------------------- 8< -------------------- 
I tried to reproduce the bug as described in Bug 38382, comment c10, however, I did not succeed so far. Therefore, I am not sure how to invoke a similar error in our test setups.

As Bug 38332 is now fixed, the UMC server component restart can be removed from the utils.sh file ucs-ec2-tools/examples/jenkins/utils.

+++ This bug was initially created as a clone of Bug #38382 +++


A tester reported that he ended up with an unconfigured UCS system. In the setup.log file, it can be seen that apt could not access the DVD drive anymore. Consequently, 05_role/10role is not able to successfully install the corresponding UCS packages as apt-get seg-faults.

-------------------- 8< -------------------- 
File: /etc/ntp.conf
__MSG__:0% [Working]
__MSG__:0% [Connecting to updates.software-univention.de]
__MSG__:0% [Connecting to updates.software-univention.de (]
__MSG__:0% [Waiting for headers]
4.0-1-errata/amd64/ ldap-utils 2.4.40-1.184.201503171335 [334 kB]
__MSG__:0% [1 ldap-utils 5,474 B/334 kB 1%]
__MSG__:Media change: please insert the disc labeled
  'UCS GNU/Linux 4.0-1 _Ucs401_ - Official Release amd64 DVD Binary-1  
in the drive '/media/cdrom/' and press enter
Error in function media_change
Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/apt/progress/text.py", line  
217, in media_change
     return raw_input() not in ('c', 'C')
EOFError: EOF when reading a line
/usr/lib/univention-system-setup/scripts/setup-join.sh: line 73:  6439  
Segmentation fault      
-------------------- 8< -------------------- 

It is not clear which exactly was the cause for this behaviour, maybe the DVD was removed before the setup wizard was executed?