Bug 38635 - udm/values fails with KeyError: 'syntax'
udm/values fails with KeyError: 'syntax'
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.1-1-errata
Assigned To: Florian Best
Jürn Brodersen
:
: 25222 29745 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-01 16:45 CEST by Florian Best
Modified: 2016-03-18 06:46 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (5.80 KB, patch)
2016-01-22 14:47 CET, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2015-06-01 16:45:12 CEST
Received traceback, 4.0-2 errata205 (Walle):

Execution of command 'udm/values users/user' has failed:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 282, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/udm/__init__.py", line 648, in values
    result = module.get_default_values(property_name)
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 392, in get_default_values
    value = read_syntax_choices(prop.syntax.name)
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 163, in _decorated
    return func(*args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 146, in wrapper_func
    return _func(*args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 139, in _func
    ret = func(*args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/udm/udm_ldap.py", line 1500, in read_syntax_choices
    syntax = udm_syntax.LDAP_Search(options['syntax'], options['filter'], options['attributes'], options['base'], options['value'], options['viewonly'], options['empty'],
options['empty_end'])
KeyError: 'syntax'
Comment 1 Florian Best univentionstaff 2016-01-22 14:07:54 CET
*** Bug 29745 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2016-01-22 14:07:58 CET
*** Bug 25222 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2016-01-22 14:08:58 CET
Reported at Ticket#2016010721000381
Comment 4 Florian Best univentionstaff 2016-01-22 14:47:10 CET
Created attachment 7426 [details]
patch
Comment 5 Florian Best univentionstaff 2016-03-04 15:53:35 CET
Problem occurs with every syntax based on LDAP_Search-syntax class.

Reproduce: Open nagios module:
Search for:
 Nagios object type: Nagios Service
 Property: Check period

univention-management-console-module-udm (6.0.11-8):
r67926 | Bug #38635: fix traceback when searching for specific values

univention-management-console-module-udm.yaml:
r67927 | YAML Bug #38635
Comment 6 Jürn Brodersen univentionstaff 2016-03-14 13:55:02 CET
What I tested:
Tested the web interface.
Tested umc-command:
umc-command udm/values -o objectType="mail/folder" -o objectProperty="mailDomain"
umc-command udm/values -o objectType="nagios/service" -o objectProperty="notificationPeriod"
-> No more Tracebacks, list of possible values is returned

Changes: OK
YAML: OK
Comment 7 Florian Best univentionstaff 2016-03-18 06:46:05 CET
<http://errata.software-univention.de/ucs/4.1/133.html>