Bug 38695 - FreeRDP Bitmap cache drawing problem
FreeRDP Bitmap cache drawing problem
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Terminal services
UCC 2.0
Other Linux
: P5 normal
: UCC 2.0-errata
Assigned To: Erik Damrose
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-12 12:27 CEST by Tim Petersen
Modified: 2015-11-20 14:14 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Petersen univentionstaff 2015-06-12 12:27:50 CEST
2015060921000147:

https://github.com/FreeRDP/FreeRDP/issues/348

"
mit dem Parameter --no-bmp-cache in rdp/additionaloptions scheint das Problem vorerst behoben zu sein.
"
Comment 1 Tim Petersen univentionstaff 2015-07-06 09:39:09 CEST
(In reply to Tim Petersen from comment #0)
> mit dem Parameter --no-bmp-cache in rdp/additionaloptions scheint das
> Problem vorerst behoben zu sein.


Das wirft an Ticket #2015070221000103 nun leider andere Probleme.

->
Assertion '!e->next' failed at pulsecore/queue.c:106, function pa_queue_pop(). Aborting.
Abgebrochen (Speicherabzug geschrieben)
Comment 2 Tim Petersen univentionstaff 2015-07-09 07:39:37 CEST
With current versions of neutrinordp (master and devel  branch) this is not fixed yet for the customer.
Comment 3 Erik Damrose univentionstaff 2015-09-03 09:58:48 CEST
I updated to the upstream neutrinordp version and built it in ucc-2.1-errata

r63419 yaml
Comment 4 Felix Botner univentionstaff 2015-09-11 09:52:28 CEST
/usr/bin/neutrinordp --ignore-certificate -a 24  -k 0x00000407 --plugin rdpsnd -f -u Administrator --plugin rdpdr --data disk local-drives /run/drives -- 10.2
00.7.80

=> SEGFAULT
Comment 5 Erik Damrose univentionstaff 2015-09-15 14:18:31 CEST
(In reply to Felix Botner from comment #4)
> => SEGFAULT


This is not a regression but also happens with the old version. It is caused by passing wrong parameters to the rdpdr plugin. I opened Bug #39347 for this. Please continue QA of this Bug.
Comment 6 Felix Botner univentionstaff 2015-09-16 12:47:16 CEST
OK - YAML
OK - neutrinordp (1.1.0.20150902)