Bug 38974 - Traceback in sources.list files should be recognized
Traceback in sources.list files should be recognized
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - System diagnostic
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Lukas Oyen
Florian Best
:
: 38988 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-18 23:23 CEST by Stefan Gohmann
Modified: 2017-09-20 15:03 CEST (History)
6 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.091
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2015071421000546
Bug group (optional): External feedback
Max CVSS v3 score:
oyen: Patch_Available+


Attachments
38974-diagnostic-traceback-sources-list-420.patch (6.34 KB, patch)
2017-06-13 16:09 CEST, Lukas Oyen
Details | Diff
38974-diagnostic-traceback-sources-list-420.patch (6.01 KB, patch)
2017-06-13 17:01 CEST, Lukas Oyen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2015-07-18 23:23:10 CEST
A traceback in one of the sources.list files should be recognized by the diagnostic module.

See Ticket #2015071421000546
Comment 1 Stefan Gohmann univentionstaff 2015-07-20 20:40:42 CEST
*** Bug 38988 has been marked as a duplicate of this bug. ***
Comment 2 Sönke Schwardt-Krummrich univentionstaff 2015-07-21 09:08:13 CEST
From Bug #38988:

> The diagnostic module should also check for other Tracebacks like
> - wrong credentials for repositories

Please note that "incorrect" credentials are currently default in several scenarios. The some apps automatically configure external 3rd party repositories to include security updates. These repos are only available for paying customers, all other users get a permission denied.
I think, it would be an incorrect signal to the user to display these tracebacks as a problem via the diagnostic module.
Comment 3 Lukas Oyen univentionstaff 2017-06-13 16:09:59 CEST
Created attachment 8919 [details]
38974-diagnostic-traceback-sources-list-420.patch

Find exception tracebacks in all files in `/etc/sources.list.d/*` and display them as a Warning.

`ConfigurationErrors` are not reported with a full traceback and are therefore
not covered by this check. This seems to be intended behaviour to me. Note that
this covers the case in comment 2.
Comment 4 Lukas Oyen univentionstaff 2017-06-13 17:01:43 CEST
Created attachment 8920 [details]
38974-diagnostic-traceback-sources-list-420.patch

Updated the regex to be more permissive (thanks Florian).
Comment 5 Lukas Oyen univentionstaff 2017-08-01 16:30:26 CEST
Committed in r81620 - r81621 (advisory r81649).
Comment 6 Florian Best univentionstaff 2017-08-01 18:46:54 CEST
* typo in german translation "Dateine"
* full sentences would be better
Comment 7 Lukas Oyen univentionstaff 2017-08-02 15:16:36 CEST
r81707: fix typo in translation of sources_list_check

The "All files ok" is just pro forma. This is in the current implementation of the diagnostic module never shown, as the overview just displays error messages. In case of an error the `description` is replaced with the actual error message.
Comment 8 Florian Best univentionstaff 2017-08-08 17:46:03 CEST
I found the following error in the sources.list by adding a new component (via the repository module):

# Configuration error: host is unresolvable: foobar

It was not detected.
Comment 9 Lukas Oyen univentionstaff 2017-08-08 18:18:17 CEST
(In reply to Florian Best from comment #8)
> I found the following error in the sources.list by adding a new component
> (via the repository module):
> 
> # Configuration error: host is unresolvable: foobar
> 
> It was not detected.

Comment 3:

> `ConfigurationErrors` are not reported with a full traceback and are therefore
> not covered by this check. This seems to be intended behaviour to me. Note that
> this covers the case in comment 2.
Comment 10 Florian Best univentionstaff 2017-08-10 13:02:18 CEST
Please add a solution button "Regenerate sources list" / "Source-Listen neu generieren" /etc.
Comment 11 Lukas Oyen univentionstaff 2017-08-10 14:29:30 CEST
(In reply to Florian Best from comment #10)
> Please add a solution button "Regenerate sources list" / "Source-Listen neu
> generieren" /etc.

Implemented in r81988.
Comment 12 Florian Best univentionstaff 2017-08-29 15:05:40 CEST
Please adjust the german translation:
+"Dieser Fehler mag durch eine erneute Generierung der Source-Listen zu "
+"beheben sein."

Maybe better:
"Dieser Fehler könnte durch eine erneute Generierung der Source-Listen behoben werden".
Comment 13 Lukas Oyen univentionstaff 2017-09-04 15:49:03 CEST
Fixed:

4.2-1: r82618, YAML: r82626
4.2-2: r82627, YAML: r82635
Comment 14 Florian Best univentionstaff 2017-09-04 16:40:16 CEST
All right.
Comment 15 Erik Damrose univentionstaff 2017-09-20 15:03:43 CEST
<http://errata.software-univention.de/ucs/4.2/166.html>