Bug 39070 - AD Takeover fails if AD NETBIOS domain name is unusual
AD Takeover fails if AD NETBIOS domain name is unusual
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: AD Takeover
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.1-1-errata
Assigned To: Arvid Requate
Felix Botner
:
: 34650 (view as bug list)
Depends on:
Blocks: 43785
  Show dependency treegraph
 
Reported: 2015-08-03 15:18 CEST by Arvid Requate
Modified: 2017-03-10 12:52 CET (History)
8 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017030621000252
Bug group (optional): Troubleshooting
Max CVSS v3 score:


Attachments
ad_netbios_domain.patch (907 bytes, patch)
2016-03-21 20:37 CET, Arvid Requate
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2015-08-03 15:18:38 CEST
Same situation as in Bug #37460: AD Takeover fails if AD NETBIOS domain name is unusual:

UCS DC set up with 

 NETBIOS domain: FOOBAR
 DNS domainname: FooBar.com

AD DC set up with

 NETBIOS domain: FOOBAR0
 DNS domainname: FooBar.com

In AD Takeover we have the additional challenge that AD Takeover method post_join_tasks_and_start_samba_without_drsuapi looks for the samba domain object in LDAP, so the workaround of Bug #37460, to manually set windows/domain to "FOOBAR0" doesn't work here.



+++ This bug was initially created as a clone of Bug #37460 +++
Comment 1 Jens Thorp-Hansen univentionstaff 2015-12-10 14:33:17 CET
happened most likely again here: Ticket#2015120921001018
Comment 2 Arvid Requate univentionstaff 2016-03-21 20:37:15 CET
Created attachment 7547 [details]
ad_netbios_domain.patch

This patch might already fix it. To be tested.
Comment 3 Arvid Requate univentionstaff 2016-03-22 15:13:16 CET
The sambadomain object on LDAP needed renaming too.

Advisory: univention-management-console-module-adtakeover.yaml
Comment 4 Felix Botner univentionstaff 2016-04-25 12:32:25 CEST
OK - takeover with ad netbios != ucs netbios
OK - takeover with ad netbios == ucs netbios
OK - univention-management-console-module-adtakeover.yaml
Comment 5 Janek Walkenhorst univentionstaff 2016-04-27 17:32:19 CEST
<http://errata.software-univention.de/ucs/4.1/158.html>
Comment 6 Arvid Requate univentionstaff 2016-10-10 21:01:09 CEST
*** Bug 34650 has been marked as a duplicate of this bug. ***