Bug 39082 - univention-upgrade should suggest App Center updates
univention-upgrade should suggest App Center updates
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1
Assigned To: Dirk Wiesenthal
Stefan Gohmann
: interim-2
Depends on: 30417
Blocks: 39839
  Show dependency treegraph
 
Reported: 2015-08-05 00:14 CEST by Dirk Wiesenthal
Modified: 2015-11-17 12:12 CET (History)
8 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2015-08-05 00:14:58 CEST
Docker support will add this functionality (big patch!). Test whether univention-upgrade still works with the (extended) patch.

+++ This bug was initially created as a clone of Bug #38697 +++

The App Center needs functions the updater can use to query and trigger for App updates.

+++ This bug was initially created as a clone of Bug #30417 +++

Using "univention-upgrade" or the Online Update UMC Module tells the user the system is up to date even if there are updates in the App Center available. It would be easier for the user to be informed about available updates or at least to be informed about the other tool/UMC-module to check for updates.
Comment 1 Stefan Gohmann univentionstaff 2015-10-05 07:21:25 CEST
We should wait for the UCS 4.0-3-errata fix: Bug #30417.
Comment 2 Dirk Wiesenthal univentionstaff 2015-10-27 00:07:29 CET
Works with new App Center in
  univention-updater 11.0.4-3.1420.201510270006
Comment 3 Stefan Gohmann univentionstaff 2015-10-27 06:43:34 CET
OK, the upgrade and the tool works as expected. One note, we've changed the default with 4.1. --enable-app-updates are now activated by default. Please add a changelog entry for this change.
Comment 4 Dirk Wiesenthal univentionstaff 2015-10-27 12:41:20 CET
Added a changelog entry
Comment 5 Stefan Gohmann univentionstaff 2015-10-28 09:31:51 CET
OK
Comment 6 Stefan Gohmann univentionstaff 2015-11-17 12:12:29 CET
UCS 4.1 has been released:
 https://docs.software-univention.de/release-notes-4.1-0-en.html
 https://docs.software-univention.de/release-notes-4.1-0-de.html

If this error occurs again, please use "Clone This Bug".