Bug 39266 - neutrinordp crash due to pulseaudio rdpsnd plugin
neutrinordp crash due to pulseaudio rdpsnd plugin
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: End user applications
UCC 2.0
Other Linux
: P5 normal
: UCC 2.0-errata
Assigned To: Erik Damrose
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 14:54 CEST by Erik Damrose
Modified: 2015-11-20 14:14 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2015-08-26 14:54:19 CEST
neutrinordp crashes when connected to a w2k8r2 server with the following error message:

Assertion 'e->mainloop->n_enabled_defer_events > 0' failed at
pulse/mainloop.c:260, function mainloop_defer_enable(). Aborting.
Aborted (Core dumped)

A customer confirmed this to be fixed in neutrinordp master - f26ff2539f7f28121bc06c9623f1ae7dea76ad35
Comment 1 Erik Damrose univentionstaff 2015-09-03 09:57:35 CEST
I updated to the upstream neutrinordp version and built it in ucc-2.1-errata

r63419 yaml
Comment 2 Felix Botner univentionstaff 2015-09-11 09:52:15 CEST
/usr/bin/neutrinordp --ignore-certificate -a 24  -k 0x00000407 --plugin rdpsnd -f -u Administrator --plugin rdpdr --data disk local-drives /run/drives -- 10.2
00.7.80

=> SEGFAULT
Comment 3 Erik Damrose univentionstaff 2015-09-15 14:18:20 CEST
(In reply to Felix Botner from comment #2)
> => SEGFAULT

This is not a regression but also happens with the old version. It is caused by passing wrong parameters to the rdpdr plugin. I opened Bug #39347 for this. Please continue QA of this Bug.
Comment 4 Felix Botner univentionstaff 2015-09-16 12:46:46 CEST
OK - neutrinordp rdp connection to w2k8r2 with sound
OK - neutrinordp (1.1.0.20150902.14)
OK - YAML