Bug 39597 - UI for Password self service
UI for Password self service
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Self Service
UCS 4.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1
Assigned To: Alexander Kramer
Daniel Tröder
: interim-2
: 39489 (view as bug list)
Depends on: 37890 39615
Blocks: 39489 39705
  Show dependency treegraph
 
Reported: 2015-10-20 10:04 CEST by Daniel Tröder
Modified: 2015-11-17 12:11 CET (History)
8 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Tröder univentionstaff 2015-10-20 10:04:53 CEST
+++ This bug was initially created as a clone of Bug #37890 +++

A UMCish UI for the two existing self service modules (password-reset and change-passwort) has to be implemented.

A stub can be found under
  management/univention-self-service/plugins/setpassword/var
and
  management/univention-self-service/plugins/passwordreset/var

A JSON-backend is running at
  /self-service/passwordreset/
and
  /self-service/setpassword/

Install packages univention-self-service* and univention-management-console-module-passwordreset on a master/backup dc.
Comment 1 Alexander Kramer univentionstaff 2015-10-29 09:40:33 CET
In discussion with Alex and Florian we decided to restructure the package to simplify the UI dependencies.

- Step 1: Preparing the directory r 64958
- Step 2: Add new and adapted files r 64962
Comment 2 Alexander Kramer univentionstaff 2015-10-29 09:56:50 CET
r 64963

* Adapted univention-self-service.install
* Removed typo in debian/univention-self-service.postinst
Comment 3 Alexander Kramer univentionstaff 2015-10-29 14:57:54 CET
r64978
Bug #39597: Adapted apache and cherrypy config. Started UI for passwordchange
Comment 4 Florian Best univentionstaff 2015-10-29 15:23:27 CET
You replaced the apache config file with the actual compiled file.
Comment 5 Alexander Kramer univentionstaff 2015-10-30 10:22:36 CET
r65003
Bug #39597: Improved UI for passwordchange
Comment 6 Alexander Kramer univentionstaff 2015-10-30 13:00:45 CET
65005(In reply to Florian Best from comment #4)
> You replaced the apache config file with the actual compiled file.

Thanks for the hint - conffile is fiex now
Still improving the ui
Comment 7 Alexander Kramer univentionstaff 2015-10-30 17:38:13 CET
r 65030
Bug #39597: Started UI for passwordreset
Comment 8 Alexander Kramer univentionstaff 2015-11-02 13:28:07 CET
r 65085
# Adapted RadioButton for passwordreset and Improved Error Message
Comment 9 Alexander Kramer univentionstaff 2015-11-02 14:39:40 CET
r 65088
Improved UI error handling
Comment 10 Florian Best univentionstaff 2015-11-02 18:41:15 CET
I added the possibility to set the language in the backend.
To support it on frontend side: Add the request header 'Accept-Language' with a value like 'de-DE'.
Comment 11 Johannes Keiser univentionstaff 2015-11-05 14:59:30 CET
r 65234
univention-self-service (1.0.1-4):
* Bug #39597: adapted UI for password reset

Version: 1.0.1-4.17.201511051456
Comment 12 Alexander Kramer univentionstaff 2015-11-06 12:13:11 CET
65273
* Bug #39597: Added an overview page if no hash is provided
Also moved some logic into a shared lib file
Comment 13 Johannes Keiser univentionstaff 2015-11-06 17:26:13 CET
r 65293
univention-self-service (1.0.1-9):
* Bug #39597: added site where the user can set his contact information

r 65294
univention-self-service (1.0.1-10):
* Bug #39597: removed fuzzy in po file
Comment 14 Florian Best univentionstaff 2015-11-09 09:07:33 CET
Your current language problem (from Bug #37890 comment 17) is probably because the package currently fails to build due to fuzzies or because the frontend still doesn't set the Accept-Language header in its requests (comment #10).
Comment 15 Alexander Kramer univentionstaff 2015-11-09 13:34:24 CET
r 65320 
univention-self-service (1.0.1-11) 

* Bug #39597: include dojo.hash to reload the page on hashChanged
Add setContact to setcontactinformation
Adapted translations

Added Accept-Language
Comment 16 Alexander Kramer univentionstaff 2015-11-09 14:43:34 CET
r65325
univention-self-service (1.0.1-12) 
* Bug #39597: Extended some links by the language query string
Comment 17 Alexander Kramer univentionstaff 2015-11-10 10:19:31 CET
The ui provides the possibility to:
- change your password
- reset your password
- set your contact information

It is also possible to provide an url, urlLabel and timer in the query string to trigger a redirect after the (re)set or change was successful:
e.g.  /univention-self-service/?url=/Test&urlLabel=Test&timer=7#setcontactinformation

It is forbidden to provide an absolute url like: http://www.univention.de
In this case the redirect will be ignored and an error is displayed in the console.

Revision 65352 übertragen.
univention-self-service (1.0.1-13) 
* Bug #39597: Finsihed setcontactinformation
* Adapted translation
* Imrpoved css styling
* Added regex to avoid redirect to absolute paths


Successful build
Package: univention-self-service
Version: 1.0.1-13.24.201511101009
Branch: ucs_4.1-0
Comment 18 Alexander Kramer univentionstaff 2015-11-10 10:33:26 CET
*** Bug 39489 has been marked as a duplicate of this bug. ***
Comment 19 Alexander Kramer univentionstaff 2015-11-10 13:05:24 CET
univention-self-service (1.0.2-2) 
* Bug #39597: Added frontend validation for mail address
* Always display inputs for mobile and email

Successful build
Package: univention-self-service
Version: 1.0.2-2.26.201511101303
User: akramer
Branch: ucs_4.1-0
Comment 20 Alexander Kramer univentionstaff 2015-11-10 13:39:02 CET
r 65377 changelog
Comment 21 Alexander Kramer univentionstaff 2015-11-11 07:24:10 CET
As discussed with Alex and Stefan we will change the input fields, so the label is shown below and not inside.
Comment 22 Alexander Kramer univentionstaff 2015-11-11 12:51:02 CET
r65407
univention-self-service (1.0.2-4) 
* Bug #39597: Adapted style and labels for input fields
* Changed labels and long desc for the overview items

Successful build
Package: univention-self-service
Version: 1.0.2-4.27.201511111247
Branch: ucs_4.1-0
Comment 23 Daniel Tröder univentionstaff 2015-11-12 17:08:25 CET
* The label of the link after changing a password is not translated:
 Passwort erfolgreich geändert.
 Back to the overview.

* Also after changing the contact data:
 Ihre Kontaktdaten wurden erfolgreich geändert.
 Back to the overview.

* Maybe change wording?: "Speichern" Button → "Speichern"-Knopf

* If a user leaves the page, gets the token and comes back, it _seems_ to not be possible to enter a token into a form without requesting a new token first. Which it then says was already sent. That is a little confusing. If there were a second button right of "Request token" that would say "Enter token" (and would then do the same xD ), it might be clearer to the user.

* There is no address where a token can be entered from a HTTP-link in a message (email/QR code). Please create a URL that can contain a token (something like https://FQDN/univention-self-service/USER/TOKEN) and will get the user right to setting a new password or an error message... or the existing page with the username and token already entered in the form.
Comment 24 Alexander Kramer univentionstaff 2015-11-13 07:49:39 CET
(In reply to Daniel Tröder from comment #23)
> * The label of the link after changing a password is not translated:
>  Passwort erfolgreich geändert.
>  Back to the overview.
> 
> * Also after changing the contact data:
>  Ihre Kontaktdaten wurden erfolgreich geändert.
>  Back to the overview.
> 
> * Maybe change wording?: "Speichern" Button → "Speichern"-Knopf

--> "Back to the overview" will now be translated.
--> I removed the term 'Button' just saying 'Drücken Sie anschließend den "Speichern, um ..."

r65476
univention-self-service (1.0.2-5) 
* Bug #39597: Adapted wording and translation
Comment 25 Alexander Kramer univentionstaff 2015-11-13 09:07:05 CET
(In reply to Daniel Tröder from comment #23)
> * If a user leaves the page, gets the token and comes back, it _seems_ to
> not be possible to enter a token into a form without requesting a new token
> first. Which it then says was already sent. That is a little confusing. If
> there were a second button right of "Request token" that would say "Enter
> token" (and would then do the same xD ), it might be clearer to the user.

Instead of a second button I adapted the description of steps. So one gets the information what to do if (a) one already have a token (b) the token is expired

It is now possible to switch between the last steps by following the corresponding link.

univention-self-service (1.0.2-6) 
* Bug #39597: Switch between passwordreset steps
Comment 26 Alexander Kramer univentionstaff 2015-11-13 10:47:15 CET
(In reply to Daniel Tröder from comment #23)
> * There is no address where a token can be entered from a HTTP-link in a
> message (email/QR code). Please create a URL that can contain a token
> (something like https://FQDN/univention-self-service/USER/TOKEN) and will
> get the user right to setting a new password or an error message... or the
> existing page with the username and token already entered in the form.

It is now possible to provide the username and token inside the query string of the url e.g.:

https://FQDN/univention-self-service/
?lang=en-US
&token=qGm9snwbZV32P97MQM2A6CX1BrBMwGza73T4p75QwcHhdLJ6Sfjkwhk1aQoYU7hQ
&username=test1
#passwordreset

Both will be displayed inside the existing page - hiding the token request node. 

r65480
univention-self-service (1.0.2-7) 
* Bug #39597: Fill passwordreset by url query string

Successful build
Package: univention-self-service
Version: 1.0.2-7.28.201511131038
Branch: ucs_4.1-0
Comment 27 Daniel Tröder univentionstaff 2015-11-13 13:23:28 CET
OK: wording
OK: translations
OK: manual functional test
Comment 28 Stefan Gohmann univentionstaff 2015-11-17 12:11:42 CET
UCS 4.1 has been released:
 https://docs.software-univention.de/release-notes-4.1-0-en.html
 https://docs.software-univention.de/release-notes-4.1-0-de.html

If this error occurs again, please use "Clone This Bug".