Bug 39794 - App Center - screenshot gallery
App Center - screenshot gallery
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1-1-errata
Assigned To: Johannes Keiser
Alexander Kläser
:
: 39851 39889 (view as bug list)
Depends on: 38894 39524
Blocks: 41038
  Show dependency treegraph
 
Reported: 2015-11-05 13:25 CET by Dirk Wiesenthal
Modified: 2016-04-13 14:57 CEST (History)
8 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Design, Usability
Max CVSS v3 score:


Attachments
appcenter_carousel.patch (21.87 KB, patch)
2016-02-01 19:10 CET, Johannes Keiser
Details | Diff
patch (66.32 KB, patch)
2016-03-08 17:23 CET, Johannes Keiser
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2015-11-05 13:25:42 CET
It took my browser ~10 seconds to load the youtube videos (due to some api calls).

Suddenly, the thumbnails appeared. This looked awkward (if not broken). We should add some kind of spinner until they are loaded.

The details pane is opened when clicking on an App, so one can witness this behaviour easily.

+++ This bug was initially created as a clone of Bug #39524 +++

One new feature of the UCS 4.1 App Center is the ability to present thumbnails of multiple screenshots in a gallery/carousel view (cf. attachment 7067 [details]).

+++ This bug was initially created as a clone of Bug #38894 +++

The UMC App Center usability should be improved. The app list is getting longer and longer. :)
Comment 1 Johannes Keiser univentionstaff 2016-02-01 19:10:04 CET
Created attachment 7446 [details]
appcenter_carousel.patch
Comment 2 Johannes Keiser univentionstaff 2016-02-01 19:42:19 CET
(In reply to Johannes Keiser from comment #1)
> Created attachment 7446 [details]
> appcenter_carousel.patch

This patch addresses following issues:
   *CarouselWidget is visible from the start while all thumbsnails are loading
   *Fixed Carousel not resizing when it contains only youtube videos
   *Added handling for broken images and youtube urls
   *left/right buttons ignore the skips previous/next index if it would
     only move a few pixels
Comment 3 Johannes Keiser univentionstaff 2016-03-08 17:16:44 CET
*** Bug 39889 has been marked as a duplicate of this bug. ***
Comment 4 Johannes Keiser univentionstaff 2016-03-08 17:17:03 CET
*** Bug 39851 has been marked as a duplicate of this bug. ***
Comment 5 Johannes Keiser univentionstaff 2016-03-08 17:23:21 CET
Created attachment 7523 [details]
patch
Comment 6 Johannes Keiser univentionstaff 2016-03-08 17:31:06 CET
(In reply to Johannes Keiser from comment #5)
> Created attachment 7523 [details]
> patch

This patch addresses following issues:
  *Renamed Carousel to ThumbnailGallery
  *Added handling for the use of the Gallery in a TitlePane
  *Added loading animation
  *Added handling for broken images and youtube urls
  *Fixed Gallery not resizing when it contains only youtube videos
  *Resizing thumbnails is not as stuttery anymore
  *a few styling changes

I will applay this patch after the next erratum and set the status of this bug to resolved
Comment 7 Johannes Keiser univentionstaff 2016-03-18 11:01:35 CET
r 68183
univention-appcenter (5.0.20-29):
Bug #39794:
*Renamed Carousel to ThumbnailGallery
*Added handling for the use of the Gallery in a TitlePane
*Added loading animation
*Added handling for broken images and youtube urls
*Fixed Gallery not resizing when it contains only youtube videos
*Resizing thumbnails is not as stuttery anymore
*a few styling changes

YAML: r 68185
Comment 8 Johannes Keiser univentionstaff 2016-03-18 12:57:34 CET
r 68186

univention-appcenter (5.0.20-30):
* Bug #39794: fixed error opening app when it has no gallery
Comment 9 Alexander Kläser univentionstaff 2016-04-12 13:41:02 CEST
Changes: OK, it looks really nice now =) . Videos are loaded on demand and the 
  error handling works fine, as well! I only found a few minor issues that 
  should be fixed in a second go.
YAML file: OK

BTW... when App Center server + youtube is not accessible, the dummy images for screenshots will be scaled down to a height of 0px when clicking on them. But IMHO, this is not really an issue.

iPad mini:
* No scroll button on the left side of the gallery
* Delay of ca. 0.5sec for scrolling to next image when pressing left/right button
IE11:
* YouTube videos are not shown... I tried some configurations, however, did nott
  succeed.
* When scrolling down on the App Center gallery page and clicking on an app, then
  the app detail page will be opened with the window having scrolled down to the
  bottom of the page.

→ I opened Bug 41038 for this.
Comment 10 Janek Walkenhorst univentionstaff 2016-04-13 14:57:44 CEST
<http://errata.software-univention.de/ucs/4.1/146.html>