Bug 39835 - Detail description in only one column
Detail description in only one column
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1
Assigned To: Alexander Kläser
Stefan Gohmann
: interim-3
: 39666 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 07:09 CET by Stefan Gohmann
Modified: 2015-11-17 12:12 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
appcenter-rows.png (324.06 KB, image/png)
2015-11-10 07:09 CET, Stefan Gohmann
Details
appcenter-rows2.png (299.61 KB, image/png)
2015-11-10 07:09 CET, Stefan Gohmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2015-11-10 07:09:04 CET
I've heard from six different people including me that the three row view of the detail text in the 4.1 App Center is hard to read and that it looks wrong.

I would like to see the description in only one column like in xrdp, see screenshot.
Comment 1 Stefan Gohmann univentionstaff 2015-11-10 07:09:26 CET
Created attachment 7268 [details]
appcenter-rows.png
Comment 2 Stefan Gohmann univentionstaff 2015-11-10 07:09:56 CET
Created attachment 7269 [details]
appcenter-rows2.png
Comment 3 Alexander Kläser univentionstaff 2015-11-11 16:50:40 CET
Fixed. I added different CSS classes according to the text length and added particular media queries for different display sizes. Here is the logic, 2 columns are shown for:

  400 characters text length AND 650px <= display width <= 767px
  500 characters text length AND 650px <= display width <= 991px
  600 characters text length AND 650px <= display width <= 1199px
  800 characters text length AND 650px <= display width

This should make it a bit more flexible. I think it looks good like that.

univention-appcenter (5.0.18-1):
r65422 | Bug #39835: Adjust multi-column layout according to text length
Comment 4 Stefan Gohmann univentionstaff 2015-11-11 22:18:53 CET
Yes, that looks really nice.
Comment 5 Stefan Gohmann univentionstaff 2015-11-12 06:20:34 CET
(In reply to Stefan Gohmann from comment #4)
> Yes, that looks really nice.

→ Verified.
Comment 6 Alexander Kläser univentionstaff 2015-11-12 13:44:36 CET
*** Bug 39666 has been marked as a duplicate of this bug. ***
Comment 7 Stefan Gohmann univentionstaff 2015-11-17 12:12:26 CET
UCS 4.1 has been released:
 https://docs.software-univention.de/release-notes-4.1-0-en.html
 https://docs.software-univention.de/release-notes-4.1-0-de.html

If this error occurs again, please use "Clone This Bug".