Bug 39954 - Connection to download server updates.software-univention.de gets stuck / stalls
Connection to download server updates.software-univention.de gets stuck / stalls
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - univention-updater
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-0-errata
Assigned To: Philipp Hahn
Stefan Gohmann
:
: 39857 (view as bug list)
Depends on: 36044
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 19:56 CET by Stefan Gohmann
Modified: 2016-01-20 13:24 CET (History)
6 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2015-11-14 19:56:27 CET
With Bug #36044 a timeout has been added and the timeout is set to 10 minutes by default. I see the problem often in Docker tests, for example here:

[2015-11-14 10:47:42.016021]Starting to download 2 file(s) directly
[2015-11-14 10:49:43.229250]Registering component for jwrc6nocod
[2015-11-14 10:49:43.438433]File: /etc/apt/sources.list.d/20_ucs-online-component.list
[2015-11-14 10:49:43.438641]
[2015-11-14 11:21:33.172589]File: /etc/apt/mirror.list
[2015-11-14 11:21:33.172793]
[2015-11-14 11:21:33.604339]File: /etc/apt/sources.list.d/15_ucs-online-version.list
[2015-11-14 11:21:33.604543]
[2015-11-14 11:21:36.950379]Get:1 http://updates-test.software-univention.de 4.0-0/all/ Release.gpg [198 B]

We should test if the problem also occur if we reduce the timeout to 30 seconds and try it once again.

+++ This bug was initially created as a clone of Bug #36044 +++

The UCS 4 installation hangs, it seems the connection to our download server is the problem:

root@ucs401:~# ps -ef | grep 11967
root     11967 11966  0 03:50 tty1     00:00:00 /usr/bin/python2.7 /usr/sbin/ucr commit
root     13305 11967  0 03:51 tty1     00:00:00 /usr/bin/python2.7
root     13808 13720  0 07:45 pts/0    00:00:00 grep 11967
root@ucs401:~# ps -ef | grep 13305
root     13305 11967  0 03:51 tty1     00:00:00 /usr/bin/python2.7
root     13810 13720  0 07:45 pts/0    00:00:00 grep 13305
root@ucs401:~# strace -p 13305
Process 13305 attached - interrupt to quit
recvfrom(3, ^C <unfinished ...>
Process 13305 detached
root@ucs401:~# ls -la /proc/13305/fd
total 0
dr-x------ 2 root root  0 Oct  3 07:46 .
dr-xr-xr-x 9 root root  0 Oct  3 04:36 ..
lr-x------ 1 root root 64 Oct  3 07:46 0 -> pipe:[243560]
l-wx------ 1 root root 64 Oct  3 07:46 1 -> pipe:[243561]
l-wx------ 1 root root 64 Oct  3 07:46 2 -> pipe:[241391]
lrwx------ 1 root root 64 Oct  3 07:46 3 -> socket:[243573]
root@ucs401:~# netstat -tupen | grep 243573
tcp        0      0 10.201.40.1:44538       176.9.114.147:80        ESTABLISHED 0          243573      13305/python2.7
root@ucs401:~# host 176.9.114.147
147.114.9.176.in-addr.arpa domain name pointer download2.software-univention.de.
root@ucs401:~#
Comment 1 Stefan Gohmann univentionstaff 2015-11-14 20:04:36 CET
I've increased the timeout for all docker tests to 2 hours: r65517. That should be reverted once this issue has been fixed.
Comment 2 Stefan Gohmann univentionstaff 2015-11-18 09:13:59 CET
*** Bug 39857 has been marked as a duplicate of this bug. ***
Comment 3 Philipp Hahn univentionstaff 2015-12-16 15:15:01 CET
Bug #28829 does not remove some temporary IP addresses 1.2.3.10[012], which was then used by some docker test when opening an http:// connection to the host.

(In reply to Stefan Gohmann from comment #0)
> [2015-11-14 10:49:43.438433]File: /etc/apt/sources.list.d/20_ucs-online-component.list
> [2015-11-14 11:21:33.172589]File: /etc/apt/mirror.list

The delay of 30m is probably caused by the timeout of 10m × 3components, as modules/univention/updater/tools.py:1610 print_component_repositories() iterates over all components.

> [2015-11-14 11:21:33.604339]File: /etc/apt/sources.list.d/15_ucs-online-version.list


r66396 | Bug #39954 up: Reduce HTTP connection timeout to 30s

Package: univention-updater
Version: 11.0.7-9.1439.201512161511
Branch: ucs_4.1-0
Scope: errata4.1-0

r66398 | Bug #39954 test: Reduce HTTP connection timeout to 30s YAML
 univention-updater.yaml

r66397 | Bug #39954 test: Reduce HTTP connection timeout to 30s

Package: ucs-test
Version: 6.0.28-7.1362.201512161512
Branch: ucs_4.1-0
Scope: errata4.1-0
Comment 4 Stefan Gohmann univentionstaff 2015-12-23 14:09:20 CET
Code review: OK

Tests: OK

YAML: OK (small adjustments: r66539)
Comment 5 Janek Walkenhorst univentionstaff 2016-01-20 13:24:46 CET
<http://errata.software-univention.de/ucs/4.1/58.html>