Bug 40069 - Abort exception not handled by AppCenter
Abort exception not handled by AppCenter
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-0-errata
Assigned To: Dirk Wiesenthal
Florian Best
:
: 37229 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 13:58 CET by Florian Best
Modified: 2016-03-08 14:00 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments
patch (3.79 KB, patch)
2016-01-12 16:34 CET, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2015-11-23 13:58:36 CET
Die Ausührung des Kommandos appcenter/query ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 283, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 191, in query
    return domain.to_dict(apps)
  File "%PY2.7%/univention/appcenter/actions/domain.py", line 97, in to_dict
    lo, pos = self._get_ldap_connection(args=None, allow_machine_connection=True)
  File "%PY2.7%/univention/appcenter/actions/credentials.py", line 184, in _get_ldap_connection
    raise Abort()
Abort


Remark:
Hallo,
ich habe mir nach der fehlerhaften Deinstallation von OpenXchange weitere Pakete deinstalliert. Wenn ich mich auf dem Server direkt anmelde kommt die Fehlermeldung "Esi sit ein
schwerer Fehler aufgetreten. Sehen Sie bitte in den Protokolldateien von KDM nach weiteren Informationen oder benachrichtigen Sie Ihren Systemverwalter" ... ;-((((
Ich versuche über die Paketverwaltung (Remotezugriff auf die UMC funktioniert noch, leider nicht mehr der AppCenter) ...

Version:
4.1-0 errata1 (Vahr)
Comment 1 Florian Best univentionstaff 2015-11-30 13:07:47 CET
Reported again, 4.1-0 errata1 (Vahr)

I found a way to reproduce this:
Install univention-demo-app on a DC slave. When the dpkg- installation messages occur in the progressbar stop the LDAP server on a DC master. After the installation of the app the
UMC session gets renewed. After this the traceback occurs.
Comment 2 Florian Best univentionstaff 2015-11-30 13:08:05 CET
Reported again, 4.0-4 errata0 (Vahr)


Remark:
Fehler tritt auf, nachdem das Updaten von 4.04 auf 4.1.0 durchgeführt und fehlgeschlagen ist. Ich habe wegen verschiedener Fehler den Server manuell neu gestartet und jetzt
funktionieren mehrere Komponenten nicht mehr. Unter Anderem die Anmeldung am Samba...
Comment 3 Florian Best univentionstaff 2016-01-05 12:49:04 CET
Reported again, 4.1-0 errata44 (Vahr)
Comment 4 Florian Best univentionstaff 2016-01-08 16:20:20 CET
Reported again, 4.1-0 errata44 (Vahr)

Remark:
I have try to install OpenVPN package, installer stop working (I have wait for him like 15-20min.)
After that  App Center displaying this error msg.
Comment 5 Florian Best univentionstaff 2016-01-12 16:34:00 CET
Created attachment 7403 [details]
patch

@Dirk: Starting point for a patch.
Comment 6 Florian Best univentionstaff 2016-01-22 10:40:49 CET
Reported again, 4.1-0 errata56 (Vahr)

Remark:
Aufruf App Center
Comment 7 Florian Best univentionstaff 2016-01-27 09:45:11 CET
Reported again, 4.1-0 errata60 (Vahr)
Comment 8 Florian Best univentionstaff 2016-01-27 09:45:37 CET
Reported again, 4.1-0 errata60 (Vahr)
Comment 9 Florian Best univentionstaff 2016-02-04 11:11:20 CET
Reported again, 4.1-0 errata35 (Vahr)
Comment 10 Dirk Wiesenthal univentionstaff 2016-02-09 02:00:39 CET
Fixed in
  univention-appcenter 5.0.19-47.104.201602090155

Improved error_handling, raise better exceptions
Comment 11 Florian Best univentionstaff 2016-02-10 13:38:43 CET
This looks way better!
YAML: OK

Further improvements for the future could be:
* HTTP Status = 503
* Close AppCenter frontend on such an error (as it looks especially ugly after the initial failed query).
* Abort-Error translations
* First-Time-Appcenter-Dialog should not be displayed if LDAP-Server is down
* Bug #40629
Comment 12 Janek Walkenhorst univentionstaff 2016-02-11 14:02:09 CET
<http://errata.software-univention.de/ucs/4.1/104.html>
Comment 13 Florian Best univentionstaff 2016-03-08 14:00:17 CET
*** Bug 37229 has been marked as a duplicate of this bug. ***