Bug 40341 - PO file header fuzzy when using univention-ucs-translation-build-package script
PO file header fuzzy when using univention-ucs-translation-build-package script
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1-0-errata
Assigned To: Florian Best
Daniel Tröder
:
: 32814 34254 40165 40167 (view as bug list)
Depends on: 38155
Blocks: 40339 40340
  Show dependency treegraph
 
Reported: 2015-12-23 18:38 CET by Daniel Orrego
Modified: 2016-02-04 14:05 CET (History)
9 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Orrego univentionstaff 2015-12-23 18:38:50 CET
+++ This bug was initially created as a clone of Bug #38155 +++

I had multiple warnings from univention-ucs-translation-build-package.py script.

* msgfmt Warnings on generated .po files:

msgfmt: <destination-lang-file.po>
  warning: PO file header fuzzy
  warning: older versions of msgfmt will give an error on this

<destination-lang-file.po>
  duplicate message definition...
  ...this is the location of the first definition

See bug 40340,attachment 7386 [details] for more details.
Comment 1 Florian Best univentionstaff 2016-01-14 10:59:03 CET
The dh_umc debhelper script called xgettext which produced *always* PO file header fuzzies (as a new PO file header gets created with missing information). As the header information are afterwards rewritten anyway the fuzzy flag will be removed now so that the warning is not shown.

The dh_umc debhelper script also doesn't create duplicated entries anymore.

univention-ucs-translation-template (3.0.1-4):
r66777 | Bug #40341: Bug #38155: be more error tolerant

univention-management-console (8.0.28-2):
r66776 | Bug #40341: remove duplicated messages, don't create metadata fuzzy warnings

univention-management-console.yaml:
r66782 | YAML Bug #40341

univention-ucs-translation-template.yaml:
r66782 | YAML Bug #40341
Comment 2 Florian Best univentionstaff 2016-01-14 11:14:31 CET
*** Bug 40165 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2016-01-14 11:16:31 CET
*** Bug 40167 has been marked as a duplicate of this bug. ***
Comment 4 Florian Best univentionstaff 2016-01-18 10:25:06 CET
*** Bug 34254 has been marked as a duplicate of this bug. ***
Comment 5 Florian Best univentionstaff 2016-01-18 10:25:29 CET
*** Bug 32814 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Tröder univentionstaff 2016-01-25 13:36:01 CET
OK: code
OK: advisories
OK: manual test:

# aptitude install univention-ucs-translation-template subversion
# svn co svn+ssh://dtroeder@billy.knut.univention.de/var/univention/svn/dev/branches/ucs-4.1/ucs-4.1-0/
# univention-ucs-translation-build-package.py -s ~/sync/ucs-4.1-0 -c de_DE -l de_DE.UTF-8:UTF-8 -n "Deutsch"

Comparing to output logged in attachment 7386 [details] from Bug #40340:

* PO files not fuzzy (for example univention-ucs-translation-de_DE/de_DE/services/univention-printserver/umc/python/printers/de_DE.po)
* No duplicate msgid warning run and non in po files.
Comment 7 Janek Walkenhorst univentionstaff 2016-01-27 16:27:32 CET
<http://errata.software-univention.de/ucs/4.1/66.html>
Comment 8 Stefan Gohmann univentionstaff 2016-01-27 20:48:48 CET
Reset to verified, univention-ucs-translation-template.yaml is missing.
Comment 9 Janek Walkenhorst univentionstaff 2016-02-04 14:05:00 CET
<http://errata.software-univention.de/ucs/4.1/98.html>