Bug 40486 - Closing user which was opened in new tab not possible
Closing user which was opened in new tab not possible
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Users
UCS 4.1
Other Linux
: P5 minor (vote)
: UCS 4.2-1-errata
Assigned To: Johannes Keiser
Florian Best
:
: 44605 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 12:49 CET by Florian Best
Modified: 2017-07-26 14:39 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.103
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Cleanup, External feedback, Usability
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (921 bytes, patch)
2017-07-11 17:25 CEST, Johannes Keiser
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-01-22 12:49:29 CET
If I open a user in a new tab and close this tab the tab doesn't get closed but a page for creating a new user is opened. The head buttons are broken afterwards.

The same goes probably for every object type.
Comment 1 Alexander Kläser univentionstaff 2016-01-25 11:09:54 CET
With groups it is working fine, thus probably a side effect of Bug 38190.
Comment 2 Hendrik Peter univentionstaff 2017-01-24 10:33:31 CET
Can confirm, just noticed this in a UCS Training.
UCS Version: 4.1-4 errata324.
Comment 3 Florian Best univentionstaff 2017-05-16 12:09:21 CEST
*** Bug 44605 has been marked as a duplicate of this bug. ***
Comment 4 Johannes Keiser univentionstaff 2017-07-11 17:25:56 CEST
Created attachment 9016 [details]
patch

Do not preload the Detailpage for users/user when the module is opened with an user object to open directly
Comment 5 Johannes Keiser univentionstaff 2017-07-11 17:40:56 CEST
(In reply to Johannes Keiser from comment #4)
> Created attachment 9016 [details]
> patch
> 
> Do not preload the Detailpage for users/user when the module is opened with
> an user object to open directly

Applied patch:

r 81054
univention-management-console-module-udm (7.0.10-17) 
* Bug #40486: Fix users opened in a new tab not being closable

YAML: r 81055 | 81056
Comment 6 Florian Best univentionstaff 2017-07-11 18:02:18 CEST
Very nice! Thanks.
OK: closing works again.
OK: YAML
Comment 7 Erik Damrose univentionstaff 2017-07-26 14:39:20 CEST
<http://errata.software-univention.de/ucs/4.2/113.html>