Bug 40561 - non-docker apps can not be upgraded to docker apps
non-docker apps can not be upgraded to docker apps
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.1-0-errata
Assigned To: Dirk Wiesenthal
Felix Botner
Depends on:
  Show dependency treegraph
Reported: 2016-02-02 15:14 CET by Felix Botner
Modified: 2016-02-11 14:02 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2016-02-02 15:14:21 CET
dudle 1.0.1-1 appcenter -> non-docker
dudle 1.0.2-1 appcenter.test -> docker

UCS 4.1 installed dudle from appcenter
Switched to appcenter.test

-> univention-app upgrade dudle
Going to upgrade Dudle (1.0.2-1)
                           Dudle 1.0.1-1 Update Notes

Bug fixes

     * The Dudle dependencies have been changed to ruby1.9.1.
Press [ENTER] to continue
dudle is not installed
Could not start the app container. It needs to be running to be upgraded!
dudle is not installed

UMC upgrade fails, too:
2.02.16 15:09:54.463  MODULE      ( ERROR   ) : Cannot install a Docker app. Use "univention-app install" or a newer version of the UMC module App Center
Comment 1 Dirk Wiesenthal univentionstaff 2016-02-09 01:58:47 CET
Fixed in
  univention-appcenter 5.0.19-47.104.201602090155

If the new App version is Docker, the new lib is used. If the new lib is used, upgrade goes like this:

 Install new version (start docker container)
 Remove old version (apt packages)
Comment 2 Felix Botner univentionstaff 2016-02-09 17:48:59 CET
Update worked, but the app webinterface wasn't online

after /etc/init.d/apache2 reload 

i could connect to the webinterface
Comment 3 Dirk Wiesenthal univentionstaff 2016-02-10 09:32:26 CET
(In reply to Felix Botner from comment #2)
> Update worked, but the app webinterface wasn't online
> after /etc/init.d/apache2 reload 
> i could connect to the webinterface

Comment 4 Felix Botner univentionstaff 2016-02-10 11:11:27 CET
The docker container host is not correctly joined into the domain, and the computer object on the host has a different name?

-> root@dudle-1455098103198756:/#  univention-ldapsearch 
ldap_bind: Invalid credentials (49)
-> root@dudle-1455098103198756:/# hostname 

-> root@master:~# udm computers/computer list

DN: cn=master,cn=dc,cn=computers,dc=four,dc=one
ARG: None

DN: cn=dudle-1455098396423027,cn=memberserver,cn=computers,dc=four,dc=one
ARG: None
Comment 5 Dirk Wiesenthal univentionstaff 2016-02-10 13:03:13 CET
Fixed in
  univention-appcenter 5.0.19-53.110.201602101300
Comment 6 Felix Botner univentionstaff 2016-02-10 14:44:50 CET
OK - update works
OK - data migration with preinst 
OK - join status
OK - outer join script
OK - yaml

example: docker app on appcenter-test
Comment 7 Janek Walkenhorst univentionstaff 2016-02-11 14:02:04 CET