Bug 40580 - Microsoft is ending support for Internet Explorer 8, 9, and 10 on January 12th
Microsoft is ending support for Internet Explorer 8, 9, and 10 on January 12th
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-1-errata
Assigned To: Jürn Brodersen
Alexander Kläser
:
Depends on: 40402 42617
Blocks: 40544
  Show dependency treegraph
 
Reported: 2016-02-04 12:11 CET by Florian Best
Modified: 2016-10-10 14:25 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Changed browser versions (1.31 KB, patch)
2016-02-10 17:12 CET, Jürn Brodersen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-02-04 12:11:18 CET
The MOTD (message of the day e.g. when logging in via SSH before appliance mode) has to be adapted, too.

base/univention-system-setup/conffiles/etc/motd.setup

+++ This bug was initially created as a clone of Bug #40402 +++

Microsoft is ending support for Internet Explorer 8, 9, and 10 on January 12th:
 https://www.microsoft.com/en-us/WindowsForBusiness/End-of-IE-support

We should show an info message if someone uses an old IE version with UMC and discontinue the IE 8, 9 and 10 support for UMC.
Comment 1 Jürn Brodersen univentionstaff 2016-02-05 10:27:42 CET
The warning message for Bug: #40402 only warns about an outdated browser version and doesn't explicitly say that older browsers aren't supported.

Is it ok to change the supported browser versions with an errata update? Or should this be fixed in the next UCS release?
As an alternative I could change the message to talk about recommended versions.
Comment 2 Alexander Kläser univentionstaff 2016-02-09 17:00:46 CET
As we will change the manual (Bug 40544), it is also fine to change the MOTD.
Comment 3 Jürn Brodersen univentionstaff 2016-02-10 17:12:21 CET
Created attachment 7468 [details]
Changed browser versions

It seems there is no german translation for these messages. Should a translation be added?
The default ssh config is setting: "SendEnv LANG LC_*" which forwards the local language settings to the server.
So it might be possible to show a german message for a client who uses german on his local machine.
Comment 4 Jürn Brodersen univentionstaff 2016-02-10 17:27:35 CET
I just looked at a more recent debian version and "SendEnv LANG LC_*" doesn't seem to be set anymore by default.
So a translation probably doesn't make much sense since most of the time it wouldn't be possible to know when to set the language to german.
Comment 5 Jürn Brodersen univentionstaff 2016-04-26 17:24:08 CEST
UCS4.1-1:

r68919: * updated supported browser versions
r68920: YAML
Package: univention-system-setup
Version: 9.0.4-7.960.201604261714
Comment 6 Alexander Kläser univentionstaff 2016-04-29 15:32:00 CEST
Changes: OK, looks good :) !
YAML file: OK, I adapted the wording [r69022].

→ VERIFIED
Comment 7 Janek Walkenhorst univentionstaff 2016-05-04 18:10:14 CEST
<http://errata.software-univention.de/ucs/4.1/164.html>