Bug 40697 - UCS 3.3 Xen update
UCS 3.3 Xen update
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Virtualization - Xen
UCS 3.3
Other Linux
: P5 enhancement (vote)
: UCS 3.3
Assigned To: Philipp Hahn
Erik Damrose
:
: 32567 (view as bug list)
Depends on: 40687
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 21:04 CET by Stefan Gohmann
Modified: 2016-06-07 21:35 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2016-02-16 21:04:50 CET
Xen should be updated to 4.1.6 (Ubuntu Precise) in UCS 3.3.
Comment 1 Philipp Hahn univentionstaff 2016-02-24 16:52:25 CET
Need newer OCaml with Deb617404 fixed <http://caml.inria.fr/mantis/view.php?id=5237>

repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p dh-ocaml
repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p ocaml
repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p findlib

Package: dh-ocaml
Version: 1.0.7~ucs3.3.6.201602241200
Branch: ucs_3.3-0

Package: ocaml
Version: 3.12.1-4~ucs3.3.23.201602241202
Branch: ucs_3.3-0

Package: findlib
Version: 1.3.1-1~ucs3.3.12.201602241644
Branch: ucs_3.3-0

XSAs fixed with this version:
xsa69.patch
xsa84-4.1.patch
xsa97-hap-4.1-prereq.patch
xsa97-hap-4.2.patch
xsa97-hap-4.2-prereq.patch
xsa148-4.1.patch
xsa149.patch
xsa150-4.1.patch
xsa151.patch
xsa152-4.5.patch
xsa153-libxl-4.2.patch
xsa155-qemut-qdisk-double-access.patch
xsa155-qemut-xenfb.patch
xsa155-xen-0001-xen-Add-RING_COPY_REQUEST.patch
xsa155-xen-0002-blktap2-Use-RING_COPY_REQUEST.patch
xsa156-4.2.patch
xsa159.patch
xsa162-qemut.patch
xsa164.patch
xsa165-4.1.patch
xsa166-4.3.patch

r16006 | Bug #40697 xen: UCS-3.3
 Re-apply missing patches to 4.1.6.1-0ubuntu0.12.04.8

r67665 | Bug #40697 xen: Switch to 4.1.6.1 from Ubuntu
 Drop our xen-4.1 package; convert to transition package

TBD: libvirt needs to be re-built as "libxen4.1" got renamed to "libxen-4.1"
Comment 2 Philipp Hahn univentionstaff 2016-02-24 16:53:24 CET
Package: xen
Version: 4.1.6.1-0ubuntu0.12.04.8~ucs3.3.19.201602241646
Branch: ucs_3.3-0

Package: xen-4.1
Version: 4.1.6.1-1.54.201602241651
Branch: ucs_3.3-0
Comment 3 Philipp Hahn univentionstaff 2016-02-25 16:30:04 CET
r16021 | Bug #40697 xen: UCS-3.3
 xen-4.1: Overwrite ...

Package: xen
Version: 4.1.6.1-0ubuntu0.12.04.8~ucs3.3.20.201602251513
Branch: ucs_3.3-0

TODO: bridge eth0...
TODO: Test
Comment 4 Philipp Hahn univentionstaff 2016-02-26 17:31:20 CET
repo_admin.py -F -p xen-tools -r 3.3-0-0-ucs

Package: xen-tools
Version: 4.2.1-1~ucs3.3.9.201602261717
Branch: ucs_3.3-0

# TBD: might not be needed and could be removed again.


repo_admin.py -F -p xen-common -r 3.3-0-0-ucs

Package: xen-common
Version: 4.1.2-1ubuntu1~ucs3.3.15.201602261721
Branch: ucs_3.3-0
Comment 5 Philipp Hahn univentionstaff 2016-03-11 17:21:29 CET
$ repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p libvirt
r16046 | Bug #40697 xen: Re-built for UCS-3.3
r16063 | Bug #40697 xen: UCS-3.3


$ repo_admin.py --cherrypick -r 3.0 --releasedest 3.3 -p python-defaults
r16058 | Bug #40697 xen: Fix broken Python dependencies
$ build-package-ng -P ucs -r 3.3-0-0 -p python-defaults
Package: python-defaults
Version: 2.6.6-3.25.201603031004
Branch: ucs_3.3-0


$ repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p sanlock
$ b33 sanlock
Package: sanlock
Version: 2.2-2~ucs3.3.3.201603031548
Branch: ucs_3.3-0


$ build-package-ng -P ucs -r 3.3-0-0 -p xen
Package: xen
Version: 4.1.6.1-0ubuntu0.12.04.8.21.201603031037
Branch: ucs_3.3-0

r67935 | Bug #40697 xen: Add transition packages
r67944 | Bug #40697 uvmm-node: xen-4.1.6.1
r67945 | Bug #40697 uvmm-node: Copyright 2016
r67947 | Bug #40697 uvmm-node: Silence ucslint
r67949 | Bug #40697 uvmm-node: More common packaging.

Package: univention-virtual-machine-manager-node
Version: 2.0.5-11.92.201603071047
Branch: ucs_3.3-0


r67937 | Bug #40697 xen: Update dependecies for xen-4.1.6.1
r67939 | Bug #40697 xen: Copyright 2016
r67956 | Bug #40697: Fix dependency on xen-utils-4.1
r67961 | Bug #40697 xen: Depends on blktap-dkms

Package: univention-xen
Version: 5.0.1-9.75.201603071504
Branch: ucs_3.3-0


$ repo_admin.py  --cherrypick -r 4.0 --releasedest 3.3 -p blktap-dkms
Package: blktap-dkms
Version: 2.0.93-0.3~ucs3.3.6.201603071345
Branch: ucs_3.3-0


$ repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p dash
 dash -c 'PATH=/usr/lib/xen-4.1/bin command -v xm'
Package: dash
Version: 0.5.7-3~ucs3.3.13.201603081452
Branch: ucs_3.3-0

$ repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p init-system-helpers
Package: init-system-helpers
Version: 1.18~bpo70+1~ucs3.3.2.201603101042
Branch: ucs_3.3-0


r68023 | Bug #32744,Bug #40697: libvirt,xen
Comment 6 Philipp Hahn univentionstaff 2016-03-22 19:34:13 CET
Package: xen-common
Version: 4.1.2-1ubuntu1.17.201603161018
Branch: ucs_3.3-0

Package: xen-4.1
Version: 4.1.6.1-4.56.201603161045
Branch: ucs_3.3-0

$ repo_admin.py --cherrypick -r 4.0 --releasedest 3.3 -p blktap

Package: blktap
Version: 2.0.90-1~ucs3.3.4.201603161138
Branch: ucs_3.3-0

Package: univention-xen
Version: 5.0.1-10.76.201603161140
Branch: ucs_3.3-0


PS: `ucr set grub/gfxmode=800x600@24 grub/vga=789` is required for domU-HVM; otherwise the terminal output is destroyed. While vga=789 is the default in UCS, 1024x768@32 seems to be too much even though Xen states this:
> When using the emulated Cirrus graphics card (vga="cirrus") and the qemu-xen-traditional device-model, the amount of video RAM is fixed at 4 MB, which is sufficient for 1024x768 at 32 bpp.
I guess part of the VRAM is used for ROM shadowing or VGA-TextMode-font-glyphs.


r68241 | Bug #40697: Fix dependency for libvirt transition

Package: univention-virtual-machine-manager-node
Version: 2.0.6-1.93.201603221708
User: phahn
Branch: ucs_3.3-0
Comment 7 Philipp Hahn univentionstaff 2016-03-24 16:32:59 CET
BUG: Hypervisor crashes hard during live migration <https://bugs.launchpad.net/ubuntu/+source/xen/+bug/1515145> (from 3.3 to 3.2)

Using a serial console I got two messages:
> (XEN) domain.c:668:d0 Attempt to change CR4 flags 00002660 -> 00000660

This was reported to be XSAVE related with several bugs in glibc,xen,linux to not properly check for working XSAVE.

> (XEN) ****************************************
> (XEN) Panic on CPU 4:
> (XEN) mm lock held by sh_page_fault__guest_4
> (XEN) ****************************************
> (XEN)
> (XEN) Manual reset required ('noreboot' specified)

There is a huge code change due to ../debian/patches/xsa97-hap-4.1-prereq.patch
There is a 2nd report: <https://bugs.launchpad.net/ubuntu/+source/xen/+bug/1515145>
Comment 8 Stefan Gohmann univentionstaff 2016-03-29 06:41:39 CEST
(In reply to Philipp Hahn from comment #7)
> BUG: Hypervisor crashes hard during live migration
> <https://bugs.launchpad.net/ubuntu/+source/xen/+bug/1515145> (from 3.3 to
> 3.2)

We don't need support this migration direction. The migration from 3.2 to 3.3 should work.
Comment 9 Philipp Hahn univentionstaff 2016-03-29 11:15:09 CEST
(In reply to Stefan Gohmann from comment #8)
> (In reply to Philipp Hahn from comment #7)
> > BUG: Hypervisor crashes hard during live migration
> > <https://bugs.launchpad.net/ubuntu/+source/xen/+bug/1515145> (from 3.3 to
> > 3.2)
> 
> We don't need support this migration direction. The migration from 3.2 to
> 3.3 should work.

It's a generic bug in *live* migration.
Comment 10 Philipp Hahn univentionstaff 2016-04-01 16:49:18 CEST
(In reply to Philipp Hahn from comment #7)
> There is a huge code change due to
> ../debian/patches/xsa97-hap-4.1-prereq.patch

Confirmed by reverting those 3 patches in a test-built.
5bf494a7bf3674f32ebaab1b70b76e5f174812a3 is missing.

r16253 | Bug #40697 xen: Fix live migration
r16254 | Bug #40697 xen: Fix live migration 2
r16255 | Bug #40697 xen: Fix live migration 3
r16284 | Bug #40697 xen: Fix live migration 4
r16285 | Bug #40697 xen: Fix live migration 5
r16286 | Bug #40697 xen: Fix live migration 6

Package: xen
Version: 4.1.6.1-0ubuntu0.12.04.8.28.201604011535
Branch: ucs_3.3-0


r16247 | Fix /etc/init.d/xendomains

Package: xen-common
Version: 4.1.2-1ubuntu1.18.201603301025
Branch: ucs_3.3-0


r68344 | Bug #40697 xen-4.1: Create transition symlinks manually
r68346 | Bug #40697 xen-4.1: Create transition symlinks manually 2
r68347 | Bug #40697 xen-4.1: Create transition symlinks manually 3

Package: xen-4.1
Version: 4.1.6.1-7.59.201604011645
Branch: ucs_3.3-0


OK: dist-upgrade 3.2-8 → 3.3-0
OK: xm migrate -l -c $VM $HOST
OK: virsh define && virsh start && virsh destroy
Comment 11 Erik Damrose univentionstaff 2016-05-04 16:00:37 CEST
(In reply to Philipp Hahn from comment #10)
> OK: dist-upgrade 3.2-8 → 3.3-0
Does unfortunately not work for me if xen is installed on the 3.2-8 machine. I opened bug 41205 for that
> OK: xm migrate -l -c $VM $HOST
> OK: virsh define && virsh start && virsh destroy
Reopen: On my ucs 3.3 machine:
root@master:~# virsh list
error: failed to connect to the hypervisor
error: no valid connection
error: internal error: Error adding file to config list

In addition, the correct python-libvirt library is not available, which causes UVMMd to fail:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/univention/management/console/protocol/modserver.py", line 95, in _load_module
    self.__module = __import__(file_, [], [], modname)
  File "/usr/lib/pymodules/python2.6/univention/management/console/modules/uvmm/__init__.py", line 40, in <module>
    from .uvmmd import UVMM_RequestBroker
  File "/usr/lib/pymodules/python2.6/univention/management/console/modules/uvmm/uvmmd.py", line 43, in <module>
    from univention.uvmm import protocol, client
  File "/usr/lib/pymodules/python2.6/univention/uvmm/protocol.py", line 42, in <module>
    from helpers import TranslatableException, N_ as _
  File "/usr/lib/pymodules/python2.6/univention/uvmm/helpers.py", line 73, in <module>
    import libvirt
  File "/usr/lib/python2.6/dist-packages/libvirt.py", line 25, in <module>
    raise lib_e
ImportError: /usr/lib/libvirt.so.0: version `LIBVIRT_PRIVATE_0.9.12' not found (required by /usr/lib/python2.6/dist-packages/libvirtmod.so)

ii  python-libvirt      0.9.12-5.130.201412031139
Comment 12 Philipp Hahn univentionstaff 2016-05-04 16:19:12 CEST
(In reply to Erik Damrose from comment #11)
> (In reply to Philipp Hahn from comment #10)
> root@master:~# virsh list
...
> ImportError: /usr/lib/libvirt.so.0: version `LIBVIRT_PRIVATE_0.9.12' not
> found (required by /usr/lib/python2.6/dist-packages/libvirtmod.so)
> 
> ii  python-libvirt      0.9.12-5.130.201412031139

$ repo_admin.py -U -p libvirt-python -d jessie -r 3.3
r16468 | Bug #40697: libvirt-python
 0002_generator-Free-strings-after-libvirt_charPtrWrap.patch is applied upstream

Package: libvirt-python
Version: 1.2.9-1~ucs3.3.4.201605041612
Branch: ucs_3.3-0

TODO: Check version in 4.0 / 4.1 and cherry-pick as needed
Comment 13 Erik Damrose univentionstaff 2016-05-12 13:51:56 CEST
Reopen: 
* Default toolstack has changed to 'xl' (see /etc/default/xen), so /etc/init.d/xendomains does not work anymore, as 'xm' is hardcoded there.
Comment 15 Philipp Hahn univentionstaff 2016-05-13 13:34:51 CEST
(In reply to Erik Damrose from comment #13)
> Reopen: 
> * Default toolstack has changed to 'xl' (see /etc/default/xen), so
> /etc/init.d/xendomains does not work anymore, as 'xm' is hardcoded there.

r16508 | Bug #40697 xen: Use Python-XM toolstack
 30_Bug40697_xm.patch

Package: xen-common
Version: 4.1.2-1ubuntu1.19.201605131313
Branch: ucs_3.3-0
Comment 16 Erik Damrose univentionstaff 2016-05-24 13:03:53 CEST
OK: Create/modify/delete/migrate VMs that were setup on 3.2 or 3.3
OK: Start/stop/VNC
OK: Setup + operation of UCS + Windows
OK: changelog
Verified
Comment 17 Stefan Gohmann univentionstaff 2016-05-27 20:35:03 CEST
*** Bug 32567 has been marked as a duplicate of this bug. ***
Comment 18 Stefan Gohmann univentionstaff 2016-06-07 21:35:50 CEST
UCS 3.3 has been released:
 https://docs.software-univention.de/release-notes-3.3-0-en.html
 https://docs.software-univention.de/release-notes-3.3-0-de.html

If this error occurs again, please use "Clone This Bug".