Bug 40747 - numeric sort of DNS pointer records
numeric sort of DNS pointer records
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - DNS
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-1-errata
Assigned To: Florian Best
Jürn Brodersen
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 16:25 CET by Florian Best
Modified: 2016-03-18 06:48 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): External feedback, Usability
Max CVSS v3 score:


Attachments
Screenshot (46.18 KB, image/jpeg)
2016-02-22 16:25 CET, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-02-22 16:25:04 CET
Created attachment 7495 [details]
Screenshot

The DNS pointer records are currently not sorted numerically.

The problem is that the values are transferred to the UMC frontend as strings instead of integers.
To get the information univention.admin.objects.description() is used. This calls syntax_class.to_string(). A handler can overwrite this with a 'description' function. I don't know if it is safe to return an integer there. So better fix it in UMC for all attributes with a short check if the string consists of only numeric values?
Comment 1 Florian Best univentionstaff 2016-02-22 18:14:11 CET
univention-management-console-module-udm (6.0.11-4):
r67618 | Bug #40747: sort PTR record (and number based properties) numerically

univention-management-console-module-udm.yaml:
r67618 | Bug #40747: sort PTR record (and number based properties) numerically
Comment 2 Florian Best univentionstaff 2016-03-16 12:38:42 CET
The fix has one problem: It doesn't sort items which aren't completely numeric e.g. '10.200' - This cannot be fixed with our current grid. We need dojo dgrid for this (Bug #32027).

The fix for sorting '10.200' in the tree has been committed:
r68133 | Bug #40747: fix sorting also in the tree view; Bug #38639: enhance formatter
Comment 3 Jürn Brodersen univentionstaff 2016-03-16 13:36:42 CET
What I checked:
Sorted DNS pointer records on the web interface.
Note: comment 2

Changes: OK.
YAML: OK.

→ VERIFIED
Comment 4 Florian Best univentionstaff 2016-03-18 06:48:59 CET
<http://errata.software-univention.de/ucs/4.1/133.html>