Bug 40831 - flatten DHCP / DNS tree + modify superordinate selection
flatten DHCP / DNS tree + modify superordinate selection
Status: RESOLVED WONTFIX
Product: UCS
Classification: Unclassified
Component: UMC - DNS
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-x
Assigned To: UMC maintainers
:
: 24414 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 18:57 CET by Florian Best
Modified: 2016-11-03 13:17 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Design, Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-03-03 18:57:06 CET
(In reply to Alexander Kläser from Bug #38878 comment #3)
> Created attachment 7050 [details]
To improve the handling of DNS zones:

1. forward zones should be displayed first;
2. the root of the tree widget can be hidden, and the same actions buttons as for the grid can be displayed over the tree widget. This more clearly separates actions to create/modify/delete zones from those to create/modify/delete records. In turn, the dialogue for creating new zones/records can be simplified, as well: creating zones does not need the field "superordinate" and the label "superordinate" can be replaced by, e.g., "DNS forward/reverse zone" for creating records.
The DHCP module should be adapted accordingly.
Comment 1 Florian Best univentionstaff 2016-03-04 12:37:04 CET
*** Bug 24414 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2016-03-11 07:42:53 CET
I reverted that the tree root is not shown anymore. The QA for displaying forward zones will be done via Bug #38639.
Comment 3 Florian Best univentionstaff 2016-11-03 13:17:15 CET
1 → is already implemented.
2 → The tree root shouldn't be hidden.

With the latest changes the creation of objects now depend on the selected node in the tree. I now think two buttons would be more confusing than the new behavior.
The only thing I could imagine what would still be nice would be drop-down-"Add" buttons like "Add DHCP Host", "Add DHCP Server"….