Bug 41083 - missing /usr/share/debootstrap/scripts/ucs411
missing /usr/share/debootstrap/scripts/ucs411
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UCS Net Installer
UCS 4.1
Other Linux
: P3 normal (vote)
: UCS 4.1-1-errata
Assigned To: Philipp Hahn
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-20 10:24 CEST by Jens Thorp-Hansen
Modified: 2016-05-04 18:18 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
missing_debootstrap_scripts_screenshot (332.61 KB, image/png)
2016-04-20 10:24 CEST, Jens Thorp-Hansen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Thorp-Hansen univentionstaff 2016-04-20 10:24:05 CEST
Ticket#2016031721000206

Repository 4.0-5: /var/lib/univention-repository/mirror/4.0/maintained/4.0-5/all/debootstrap-udeb_1.0.48.50.201603311225_all.udeb 

Repository 4.1-1: /var/lib/univention-repository/mirror/4.1/maintained/4.1-1/all/debootstrap-udeb_1.0.48.49.201602121416_all.udeb

The netinstaller uses preferable the newer debootstrap-udeb_1.0.48.50.201603311225_all.udeb and misses the script /usr/share/debootstrap/scripts/ucs411

Screenshot attached

Workaround: 

Add the following line to the /var/lib/univention-client-boot/preseed/FILE:

d-i partman/early_command string ln -sf /usr/share/debootstrap/scripts/wheezy /usr/share/debootstrap/scripts/ucs411
Comment 1 Jens Thorp-Hansen univentionstaff 2016-04-20 10:24:36 CEST
Created attachment 7603 [details]
missing_debootstrap_scripts_screenshot
Comment 2 Philipp Hahn univentionstaff 2016-04-27 08:40:30 CEST
There are other packages, which are now newer in 4.0-5 than in 4.1-1, "libc6-udeb" for example. This least to SEGV in "resolv.so" during PXE installation.
- We will patch univention-repository-update to filter out previous releases for now.
- debootstrap will be fixed with 4.1-2, which will be released at the beginning of May 2016.
Comment 3 Philipp Hahn univentionstaff 2016-04-27 19:51:53 CEST
r68974 | Bug #41083 up: Filter out previous releases

Package: univention-updater
Version: 11.0.9-6.1468.201604271907
Branch: ucs_4.1-0
Scope: errata4.1-1

r68979 | Bug #41083,Bug #41165,Bug #41166: updater YAML
 univention-updater.yaml
Comment 4 Philipp Hahn univentionstaff 2016-04-28 14:37:29 CEST
r68991 | Bug #41083 up: Filter out previous releases
 Fixed 2nd case

Package: univention-updater
Version: 11.0.9-7.1469.201604281433
Branch: ucs_4.1-0
Scope: errata4.1-1

r68992 | Bug #41083 up: Filter out previous releases YAML
 univention-updater.yaml
Comment 5 Felix Botner univentionstaff 2016-05-03 15:00:01 CEST
OK - dists packages files (major release packages are preferred)
OK - univention-updater.yaml
Comment 6 Janek Walkenhorst univentionstaff 2016-05-04 18:18:19 CEST
<http://errata.software-univention.de/ucs/4.1/172.html>