Bug 41204 - HTML code in notification window
HTML code in notification window
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Network settings
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.2-0-errata
Assigned To: Florian Best
Richard Ulmer
:
: 44195 44703 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-04 14:01 CEST by Timo Denissen
Modified: 2017-06-19 15:04 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.103
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2016071921000651
Bug group (optional): Design, External feedback
Max CVSS v3 score:
best: Patch_Available+


Attachments
Error message (13.29 KB, image/png)
2016-05-04 14:02 CEST, Timo Denissen
Details
patch (5.53 KB, patch)
2016-10-20 12:24 CEST, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Denissen univentionstaff 2016-05-04 14:01:42 CEST
When changing network settings using the UMC, the changes that will be commited are bordered by HTML tags:

The following changes will be applied to the system:

Network interfaces: <ul><li>Modified:<ul><li>eth0 (Ethernet): Static: 10.200.23.159/24, 10.200.23.158/24</li></ul></li></li></ul>
Please confirm to apply these changes to the system. This may take some time.
Comment 1 Timo Denissen univentionstaff 2016-05-04 14:02:00 CEST
Created attachment 7639 [details]
Error message
Comment 2 Florian Best univentionstaff 2016-05-04 14:11:24 CEST
Caused by svn r66243.
Comment 3 Florian Best univentionstaff 2016-07-20 10:02:54 CEST
Reported in Ticket#2016071921000651
Comment 4 Florian Best univentionstaff 2016-10-20 12:24:53 CEST
Created attachment 8138 [details]
patch
Comment 5 Florian Best univentionstaff 2017-03-31 16:03:46 CEST
*** Bug 44195 has been marked as a duplicate of this bug. ***
Comment 6 Florian Best univentionstaff 2017-05-29 12:34:32 CEST
*** Bug 44703 has been marked as a duplicate of this bug. ***
Comment 7 Florian Best univentionstaff 2017-05-29 12:43:02 CEST
I applied the patch.

univention-system-setup (10.0.10-18):
r79709 | Bug #41204: fix duplicated html escaping in network settings dialog

univention-system-setup.yaml:
r79710 | YAML Bug #41204
Comment 8 Richard Ulmer univentionstaff 2017-05-29 13:13:50 CEST
Looks good now. The modules "Certificate settings" and "Language settings" are unaffected (which is good). -> Verified
Comment 9 Janek Walkenhorst univentionstaff 2017-06-19 15:04:47 CEST
<http://errata.software-univention.de/ucs/4.2/50.html>