Bug 41224 - UMC login dialog isn't visible in chrome 51
UMC login dialog isn't visible in chrome 51
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-2-errata
Assigned To: Florian Best
Johannes Keiser
:
Depends on:
Blocks: 41391 41395
  Show dependency treegraph
 
Reported: 2016-05-09 16:08 CEST by Jens Thorp-Hansen
Modified: 2016-09-29 17:31 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.429
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted after Product Owner Review:
Ticket number:
Bug group (optional): Browser compatibility, External feedback, Mobile devices/tablets
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (1.10 KB, patch)
2016-05-10 08:53 CEST, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Thorp-Hansen univentionstaff 2016-05-09 16:08:37 CEST
Ticket#2016050921000316

Customer tested with Android 5.1 (Sony Xperia X3 Compact - Stock ROM) and 6 (Nexus 10 - CyanogenMOD) in UCS 4.1-1 latest errata

Customer reports it is currently not possible to use the UMC with the above Android devices - the login dialogue is not working.
Comment 1 Florian Best univentionstaff 2016-05-10 07:45:13 CEST
(In reply to Jens Thorp-Hansen from comment #0)
> Android devices - the login dialogue is not working.
is not working or is not shown?
Comment 2 Jens Thorp-Hansen univentionstaff 2016-05-10 07:46:12 CEST
If I understand the customer correctly, it is not showing.
Comment 3 Daniel Tröder univentionstaff 2016-05-10 08:09:37 CEST
Maybe related: UMC login isn't usable on Chrome beta (v51) and neither on Chrome unstable (v52).
Comment 4 Florian Best univentionstaff 2016-05-10 08:11:42 CEST
He is probably using the built in browser?
It would be good to know if he remembers the exact version where it was still working.
Comment 5 Florian Best univentionstaff 2016-05-10 08:15:51 CEST
(In reply to Daniel Tröder from comment #3)
> Maybe related: UMC login isn't usable on Chrome beta (v51) and neither on
> Chrome unstable (v52).
I can reproduce this:

Uncaught ReferenceError: normal is not defined

(anonymous function) (VM267:1)
g (dojo.js.uncompressed.js:29590)
l (load-css.js.unc…pressed.js:236)
l (load-css.js.unc…pressed.js:198)
d.(anonymous function).d.(anonymous function) (load-css.js.unc…pressed.js:151)
Comment 6 Florian Best univentionstaff 2016-05-10 08:19:24 CEST
Here is the upstream fix for xstyle:
https://github.com/kriszyp/xstyle/commit/7acb8186ccee813802625ca600eda2e307f9542c
Comment 7 Florian Best univentionstaff 2016-05-10 08:53:53 CEST
Created attachment 7647 [details]
patch

We currently use xstyle-0.2.1. The fix is part of xstyle 0.3.2.
Attached is a patch which only backports that specific issue.
Comment 8 Florian Best univentionstaff 2016-05-10 09:26:16 CEST
Customer feedback:
In Google Chrome 50.0.2661.89 all is working,
In Google Chrome beta 51.0.2704.36 not anymore.
Comment 9 Florian Best univentionstaff 2016-05-11 15:14:44 CEST
The patch has been applied.

univention-management-console-frontend.yaml:
r69255 | YAML Bug #41017 Bug #41224

univention-management-console-frontend (5.0.63-43):
r69254 | Bug #41224: version dump due to rebuild
r69253 | Bug #41224: version dump due to rebuild

univention-dojo.yaml:
r69255 | YAML Bug #41017 Bug #41224

univention-dojo (9.0.1-2):
r69251 | Bug #41224: fix an error in xstyle which prevents using xstyle with Chrome 51
Comment 10 Johannes Keiser univentionstaff 2016-05-11 19:01:48 CEST
Tested with:

Google Chrome: Version: 50.0.2661.75
  ucs4.1-1 latest errata
    UMC is shown
  ucs4.1-2 with patch
    UMC is shown

Google Chrome: Version: 51.0.2704.36 beta
  ucs4.1-1 latest errata
    UMC not shown
  ucs4.1-2 with patch
    UMC is shown

Google Chrome: Version: 52.0.2729.3 dev
  ucs4.1-1 latest errata
    UMC not shown
  ucs4.1-2 with patch
    UMC is shown

Fix works
-> Verified
Comment 11 Johannes Keiser univentionstaff 2016-05-11 19:04:39 CEST
(In reply to Johannes Keiser from comment #10)
> Tested with:
> 
> Google Chrome: Version: 50.0.2661.75
>   ucs4.1-1 latest errata
>     UMC is shown
>   ucs4.1-2 with patch
>     UMC is shown
> 
> Google Chrome: Version: 51.0.2704.36 beta
>   ucs4.1-1 latest errata
>     UMC not shown
>   ucs4.1-2 with patch
>     UMC is shown
> 
> Google Chrome: Version: 52.0.2729.3 dev
>   ucs4.1-1 latest errata
>     UMC not shown
>   ucs4.1-2 with patch
>     UMC is shown
> 
> Fix works
> -> Verified

I meant login dialogue shown/not shown