Bug 41293 - Add new feature of OU-spanning users to UCS@school user wizard
Add new feature of OU-spanning users to UCS@school user wizard
Status: CLOSED FIXED
Product: UCS@school
Classification: Unclassified
Component: UMC - Wizards
UCS@school 4.1 R2
Other Linux
: P5 normal (vote)
: UCS@school 4.1 R2
Assigned To: Florian Best
Daniel Tröder
:
: 35660 40598 40940 41534 41593 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-18 15:57 CEST by Sönke Schwardt-Krummrich
Modified: 2016-09-30 12:16 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
intermediate patch (8.54 KB, patch)
2016-05-20 15:51 CEST, Jürn Brodersen
Details | Diff
intermediate patch 2 (8.41 KB, patch)
2016-05-31 16:16 CEST, Johannes Keiser
Details | Diff
intermediate patch 3 (9.18 KB, patch)
2016-05-31 16:50 CEST, Johannes Keiser
Details | Diff
patch (8.61 KB, patch)
2016-06-01 11:36 CEST, Jürn Brodersen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2016-05-18 15:57:23 CEST
The new feature "OU-spanning users" has to be added to the UCS@school user wizard "Schüler (Schulen)".

The following changes are planned:

1) In the grid the column "School"/"Schule" shall be moved from first column 
   to last column.

2) The column "Schule" should contain a comma-separated list of display names 
   of the OUs; currently only the name of the OU is shown and not the 
   displayName if the OU object

3) The add/modify wizard should contain a new widget that shows the list of OUs 
   (Display Names) the current user is member of. This new widget shall be 
   always read-only. During "add" action, the current OU is added by default.

4) Above of the grid, there shall be a new button (called something like 
   "Benutzer aus anderer Schule importieren"). This new action shall enable 
   domain admins/school admins to search for users in a foreign school and add 
   them to their local school.

   Please note: 
   if the school admin / domain admin has access to more than one OU, the 
   dialog should enable the admin to interactively select to which OU the 
   selected user shall be added.

5) When deleting users, it has to be checked if users are selected that are 
   member of more than one school OU. If this is the case, a popup asks the 
   admin, if the multi-OU-users shall be "unsubscribed" from local OU *XOR* if 
   the user objects shall be removed from LDAP.

5a) Problem: what do we do if the school admin is member of more than one OU 
    and the admin is trying to "remove" multi-OU-users? The admin has to decide 
    from which OU the selected user is "unsubscribed".
Comment 1 Jürn Brodersen univentionstaff 2016-05-20 15:51:14 CEST
Created attachment 7675 [details]
intermediate patch

This patch addresses the following:
* moved column "School"
* column "School" contains a list
* show the schools a user is member of on the edit wizard
    * currently also shown for new users, is that ok?
* adds a copy user wizard
    * currently without a connection to backend -> empty fields
Comment 2 Johannes Keiser univentionstaff 2016-05-31 16:16:34 CEST
Created attachment 7709 [details]
intermediate patch 2

as discussed this bug removes the user copy wizard.
Instead a form that ask the user on which school the admin wants to edit users is
added after opening the "Users (schools)" module.
Comment 3 Johannes Keiser univentionstaff 2016-05-31 16:50:46 CEST
Created attachment 7710 [details]
intermediate patch 3
Comment 4 Johannes Keiser univentionstaff 2016-05-31 16:52:18 CEST
(In reply to Johannes Keiser from comment #2)
> Created attachment 7709 [details]
> intermediate patch 2
> 
> as discussed this bug removes the user copy wizard.
> Instead a form that ask the user on which school the admin wants to edit
> users is
> added after opening the "Users (schools)" module.

if there is only one school skip the choose school page
Comment 5 Jürn Brodersen univentionstaff 2016-06-01 11:36:27 CEST
Created attachment 7712 [details]
patch

Remove school column from user grid.
Remove list of schools from user wizard.
Comment 6 Sönke Schwardt-Krummrich univentionstaff 2016-06-05 22:51:27 CEST
Florian: please get in touch with Jürn and help to implement resp. implement missing backend functionality.
Comment 7 Florian Best univentionstaff 2016-06-08 16:20:27 CEST
The translation is currently missing. Jürn can you add and commit it?
Comment 8 Jürn Brodersen univentionstaff 2016-06-09 10:25:07 CEST
(In reply to Florian Best from comment #7)
> The translation is currently missing. Jürn can you add and commit it?

Done.

Also when deleting a user the selected school is now send and not the ou.
r70006: send the currently selected school when deleting a user

Could you implement that the school gets removed from "ucsschoolSchool" as long as there is more than one school for the user? And delete the user if it was the last school the user was in.

Is it a problem that a user could be only in school "A" but is saved under the ou from school "B"?
Comment 9 Florian Best univentionstaff 2016-06-13 09:19:51 CEST
*** Bug 41534 has been marked as a duplicate of this bug. ***
Comment 10 Florian Best univentionstaff 2016-06-13 11:51:28 CEST
*** Bug 40940 has been marked as a duplicate of this bug. ***
Comment 11 Florian Best univentionstaff 2016-06-13 12:07:23 CEST
*** Bug 35660 has been marked as a duplicate of this bug. ***
Comment 12 Florian Best univentionstaff 2016-06-13 12:07:53 CEST
*** Bug 40598 has been marked as a duplicate of this bug. ***
Comment 13 Florian Best univentionstaff 2016-06-16 11:22:00 CEST
New delete behavior:
The user is only completely removed if he/she is part of only ONE school.
Otherwise he gets removed from the selected school. If that school is the school where he/she lies under he/she is moved to a random other school where he is part of.

The fix is unfinished but will continue at Bug #41593.
Comment 14 Florian Best univentionstaff 2016-06-16 14:16:18 CEST
*** Bug 41593 has been marked as a duplicate of this bug. ***
Comment 15 Florian Best univentionstaff 2016-06-16 14:16:42 CEST
(In reply to Florian Best from comment #14)
> *** Bug 41593 has been marked as a duplicate of this bug. ***

This has been done here now.
Comment 16 Daniel Tröder univentionstaff 2016-06-17 12:42:21 CEST
OK: code changes in commits with 'Bug #41293' in subject
OK: users are found and displayed in correct schools, with correct classes
OK: if a user is removed from a school, the account is kept
OK: if a user is removed from an addition school, the other schools are kept
OK: if a user is removed from its primary school (position), a school move is performed
Comment 17 Florian Best univentionstaff 2016-06-28 18:24:51 CEST
UCS@school 4.1 R2 has been released:
http://docs.software-univention.de/release-notes-ucsschool-4.1R2v1-de.pdf

If this error occurs again, please use "Clone This Bug".