Bug 41294 - cancel() not called when creating object fails
cancel() not called when creating object fails
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Johannes Keiser
Florian Best
:
: 35834 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-18 18:54 CEST by Florian Best
Modified: 2017-07-26 14:39 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.171
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Error handling, External feedback, Troubleshooting, Usability
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (2.45 KB, patch)
2016-05-18 18:54 CEST, Florian Best
Details | Diff
patch (1.42 KB, patch)
2016-06-30 16:46 CEST, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-05-18 18:54:15 CEST
Created attachment 7668 [details]
patch

If for whatever reason (e.g. object class violation) the creation of a UDM object fails the cancel() method is not called.
This results e.g. in some locks not to be released.
E.g. recreating a user where this error occurred causes that one needs to save it twice to remove the uid-lock because that wasn't cleaned up in the previous call.

Attached is a patch which fixes this.
Comment 1 Florian Best univentionstaff 2016-05-19 09:32:54 CEST
*** Bug 35834 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2016-06-29 16:08:00 CEST
*** Bug 29684 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2016-06-29 16:09:40 CEST
*** Bug 28632 has been marked as a duplicate of this bug. ***
Comment 4 Florian Best univentionstaff 2016-06-30 16:46:25 CEST
Created attachment 7778 [details]
patch

rebase patch.
Comment 5 Florian Best univentionstaff 2016-06-30 17:00:12 CEST

*** This bug has been marked as a duplicate of bug 41711 ***
Comment 6 Johannes Keiser univentionstaff 2017-07-06 14:45:21 CEST
(In reply to Florian Best from comment #4)
> Created attachment 7778 [details]
> patch
> 
> rebase patch.

Applied patch:

r 80917
univention-directory-manager-modules (12.0.17-65) 
* Bug #41294: Applied patch from Florian Best - Call cancel() when creation
of UDM object fails

YAML: r 80918
Comment 7 Florian Best univentionstaff 2017-07-08 13:43:01 CEST
*** Bug 35834 has been marked as a duplicate of this bug. ***
Comment 8 Florian Best univentionstaff 2017-07-08 13:47:46 CEST
OK: error handling is correct now
OK: YAML (adjusted in r80987)
Comment 9 Erik Damrose univentionstaff 2017-07-26 14:39:23 CEST
<http://errata.software-univention.de/ucs/4.2/115.html>