Bug 41532 - Requirements before an upgrade are tested against the installed version, not the new one
Requirements before an upgrade are tested against the installed version, not ...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other Linux
: P1 normal (vote)
: UCS 4.1-2-errata
Assigned To: Dirk Wiesenthal
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-11 01:53 CEST by Dirk Wiesenthal
Modified: 2016-09-22 07:23 CEST (History)
0 users

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.154
Enterprise Customer affected?:
School Customer affected?:
ISV affected?: Yes
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2016-06-11 01:53:24 CEST
E.g., RequiredUCSVersion does nothing if only set on the latest version. When upgrading, RequiredUCSVersion from the installed version is taken.
Comment 1 Dirk Wiesenthal univentionstaff 2016-06-13 11:13:52 CEST
Fixed in
  univention-appcenter 5.0.21-7.170.201606131112
Comment 2 Felix Botner univentionstaff 2016-06-21 10:20:49 CEST
The actual error message is a bit weired, but it works

   2 errors occurred:
    (must_have_fitting_ucs_version)
    Unable to upgrade dudle. Aborting...

OK - univention-appcenter.yaml
Comment 3 Janek Walkenhorst univentionstaff 2016-06-29 12:26:39 CEST
<http://errata.software-univention.de/ucs/4.1/206.html>