Bug 41601 - add user to certain groups, when adding it to another school
add user to certain groups, when adding it to another school
Status: CLOSED FIXED
Product: UCS@school
Classification: Unclassified
Component: Ucsschool-lib
UCS@school 4.1 R2
Other Linux
: P5 normal (vote)
: UCS@school 4.1 R2 vXXX
Assigned To: Florian Best
Daniel Tröder
:
: 41643 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-17 12:47 CEST by Daniel Tröder
Modified: 2016-10-06 08:53 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.257
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Tröder univentionstaff 2016-06-17 12:47:36 CEST
When a User (staff, student, teacher, teacherandstaff, administartor?) is added (not moved) to an additional school, it must also be added to the group "Domain Users <ou>" as well as the respective schueler-<ou>, staff-<ou> etc.
Comment 1 Florian Best univentionstaff 2016-06-23 09:20:26 CEST
*** Bug 41643 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2016-06-23 10:15:04 CEST
ucs-school-lib (9.0.20-5):
r70565 | Bug #41601: add user to groups groups of all schools where he is member of

ucs-school-lib.yaml:
r70566 | YAML Bug #41601
Comment 3 Florian Best univentionstaff 2016-06-23 10:17:47 CEST
*** Bug 41640 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Tröder univentionstaff 2016-07-01 11:54:58 CEST
OK: Code changes
OK: advisory (changed wording r70761)
OK: manual test:

astudent1 = Student(name="astudent1", firstname="fn1", lastname="ln1", school="schule1", school_classes={"schule1": ["schule1-1A"]})
astudent1.create(lo)
  → True
astudent1 = Student.from_dn(astudent1.dn, astudent1.school, lo)
print("school: {}\nschools: {}\nschool_classes: {}\ngroups_used: {}".format(
    astudent1.school, astudent1.schools, astudent1.school_classes, astudent1.groups_used(lo)))
  → school: schule1
  → schools: ['schule1']
  → school_classes: {'schule1': ['schule1-1A']}
  → groups_used: ['cn=Domain Users schule1,cn=groups,ou=schule1,dc=uni,dc=dtr', 'cn=schule1-1A,cn=klassen,cn=schueler,cn=groups,ou=schule1,dc=uni,dc=dtr', 'cn=schueler-schule1,cn=groups,ou=schule1,dc=uni,dc=dtr']

astudent1.schools.append("schule2")
astudent1.modify(lo)
  → True
print("school: {}\nschools: {}\nschool_classes: {}\ngroups_used: {}".format(
    astudent1.school, astudent1.schools, astudent1.school_classes, astudent1.groups_used(lo)))
  → school: schule1
  → schools: ['schule1', 'schule2']
  → school_classes: {'schule1': ['schule1-1A']}
  → groups_used: ['cn=Domain Users schule1,cn=groups,ou=schule1,dc=uni,dc=dtr', 'cn=Domain Users schule2,cn=groups,ou=schule2,dc=uni,dc=dtr', 'cn=schule1-1A,cn=klassen,cn=schueler,cn=groups,ou=schule1,dc=uni,dc=dtr', 'cn=schueler-schule1,cn=groups,ou=schule1,dc=uni,dc=dtr', 'cn=schueler-schule2,cn=groups,ou=schule2,dc=uni,dc=dtr']
Comment 5 Daniel Tröder univentionstaff 2016-09-15 09:49:19 CEST
A test for this is in 90_ucsschool/80_move_users_into_another_ou.
Comment 6 Sönke Schwardt-Krummrich univentionstaff 2016-10-04 13:24:46 CEST
UCS@school 4.1 R2 v5 has been released.

http://docs.software-univention.de/changelog-ucsschool-4.1R2v5-de.html

If this error occurs again, please clone this bug.