Bug 41619 - "NoSuchProcess: process no longer exists" in adconnector
"NoSuchProcess: process no longer exists" in adconnector
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - AD Connector
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Johannes Keiser
Florian Best
:
: 37681 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-21 09:44 CEST by Florian Best
Modified: 2017-11-01 13:49 CET (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 7: Crash: Bug causes crash or data loss
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.240
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number: 2017030721000027, 2017062621001002
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:
best: Patch_Available+


Attachments
patch (764 bytes, patch)
2016-06-21 09:44 CEST, Florian Best
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-06-21 09:44:51 CEST
Created attachment 7756 [details]
patch

The module initialization fails with the traceback below which prevents using the module. Attached is a patch.

Version: 4.1-2 errata202 (Vahr)

Remark: Ran latest update

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/protocol/modserver.py", line 271, in handle
    self.__handler.init()
  File "%PY2.7%/univention/management/console/modules/adconnector/__init__.py", line 118, in init
    self.__update_status()
  File "%PY2.7%/univention/management/console/modules/adconnector/__init__.py", line 327, in __update_status
    self.status_running = self.__is_process_running('*python*univention/connector/ad/main.py*')
  File "%PY2.7%/univention/management/console/modules/adconnector/__init__.py", line 333, in __is_process_running
    cmdline =  proc.cmdline() if callable(proc.cmdline) else proc.cmdline
  File "%PY2.7%/psutil/__init__.py", line 330, in cmdline
    return self._platform_impl.get_process_cmdline()
  File "%PY2.7%/psutil/_pslinux.py", line 437, in wrapper
    raise NoSuchProcess(self.pid, self._process_name)
NoSuchProcess: process no longer exists (pid=24802)
Comment 1 Florian Best univentionstaff 2017-04-21 11:59:53 CEST
 Version: 4.1-4 errata406 (Vahr)
Comment 2 Florian Best univentionstaff 2017-05-19 14:17:38 CEST
*** Bug 37681 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2017-06-27 10:05:59 CEST
Reported again, 4.1-4 errata430 (Vahr)
Comment 4 Johannes Keiser univentionstaff 2017-07-06 18:10:23 CEST
(In reply to Florian Best from comment #0)
> Created attachment 7756 [details]
> patch

Applied patch:

r 80938
univention-ad-connector (11.0.6-9) 
* Bug #41619: Applied patch from Florian Best - Catch NoSuchProcess
exception

YAML: r 80939
Comment 5 Florian Best univentionstaff 2017-07-08 13:08:44 CEST
OK: error handling
OK: YAML (adjusted in r80986)
Comment 6 Arvid Requate univentionstaff 2017-11-01 13:49:22 CET
<http://errata.software-univention.de/ucs/4.2/205.html>