Bug 41657 - Listener sometimes skips transactions during a listener restart - 3.3-0 backport
Listener sometimes skips transactions during a listener restart - 3.3-0 backport
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Listener (univention-directory-listener)
UCS 3.3
Other Linux
: P5 normal (vote)
: UCS 3.3-0-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on: 41261 41486
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-24 06:34 CEST by Stefan Gohmann
Modified: 2016-10-04 13:27 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 7: Crash: Bug causes crash or data loss
Who will be affected by this bug?: 5: Will affect all installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.600
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2016-06-24 06:34:01 CEST
Backport to UCS 3.3.

+++ This bug was initially created as a clone of Bug #41486 +++

+++ This bug was initially created as a clone of Bug #41261 +++

Package: univention-directory-listener
Version: 8.0.4-2.316.201606071758
Branch: ucs_3.2-0
Scope: errata3.2-8

r69920 | Bug #41261 UDL: Write notifier ID atomically YAML
 univention-directory-listener.yaml
Comment 1 Philipp Hahn univentionstaff 2016-06-27 10:50:05 CEST
 8.0.4-2.316.201606071758   |     3 |     2 |     8 | errata    | apt
 8.100.5-5.308.201603301645 |     3 |     3 |     0 |           | apt
 9.0.2-1.239.201409081755   |     4 |     0 |     0 |           | apt

r70625 | Bug #41261 UDL: Write notifier ID atomically

Package: univention-directory-listener
Version: 8.100.5-6.322.201606271045
Branch: ucs_3.3-0
Scope: errata3.3-0

r70626 | Bug #41261 UDL: Write notifier ID atomically YAML
 univention-directory-listener.yaml
Comment 2 Arvid Requate univentionstaff 2016-07-12 21:18:16 CEST
Code review: Ok
Versioning: Ok
Advisory: Ok (typo fixed)

Reopened due to Bug 41486 Comment 2
Comment 3 Arvid Requate univentionstaff 2016-07-13 13:07:17 CEST
Patch efficiency confirmed via Bug 41486 Comment 3.
Comment 4 Janek Walkenhorst univentionstaff 2016-07-21 13:32:05 CEST
<http://errata.software-univention.de/ucs/3.3/12.html>