Bug 42032 - Apps->kix2016-> App Autotest MultiEnv -> s4,slave: some mail tests fail
Apps->kix2016-> App Autotest MultiEnv -> s4,slave: some mail tests fail
Status: CLOSED FIXED
Product: UCS Test
Classification: Unclassified
Component: Mail
unspecified
Other Linux
: P5 normal (vote)
: UCS 4.1-3-errata
Assigned To: Daniel Tröder
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-18 19:08 CEST by Felix Botner
Modified: 2016-09-29 17:14 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
log.tar.bz2 (3.48 MB, application/x-bzip)
2016-08-18 19:10 CEST, Felix Botner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2016-08-18 19:08:08 CEST
http://jenkins.knut.univention.de:8080/job/UCS-4.1/job/Apps/job/kix2016/job/App%20Autotest%20MultiEnv/SambaVersion=s4,Systemrolle=slave/15/testReport/

very strange, some early tests fail but after 7 test or so, it works

40_mail.07pop_login.test:
(2016-08-18 08:09:03.736432)   File "/usr/lib/python2.7/poplib.py", line 350, in __init__
(2016-08-18 08:09:03.749626)     raise socket.error, msg
(2016-08-18 08:09:03.749795) socket.error: [Errno 111] Connection refused

dovecot.log
Aug 18 08:09:04 slave105 dovecot: master: Dovecot v2.2.13 starting up for imap, lmtp, sieve, pop3 (core dumps disabled)
Aug 18 08:09:04 slave105 dovecot: ssl-params: Warning: Regenerating /var/lib/dovecot/ssl-parameters.dat for ssl_dh_parameters_length=2048
Aug 18 08:09:04 slave105 dovecot: ssl-params: Generating SSL parameters
Aug 18 08:09:07 slave105 dovecot: ssl-params: SSL parameters regenerat

Why is the mailserver started after ucs-test is started?
Comment 1 Felix Botner univentionstaff 2016-08-18 19:10:00 CEST
Created attachment 7897 [details]
log.tar.bz2

/var/log/ from the slave
Comment 2 Felix Botner univentionstaff 2016-08-31 10:57:30 CEST
This happens for all app tests, but only on slave/s4 + mailserver.

The mail test run fine on slave/s3 + mailserver.

Added config-registry.replog to autotest-105-app-slave-s4.cfg
Comment 3 Daniel Tröder univentionstaff 2016-08-31 13:19:37 CEST
It seems to be a timing issue: Dovecot ist started first with the Debian configuration. It starts a SSL parameters generation for 512 bit. Then univention-mail-dovecot changes the Dovecot-configuration and in the postinst does a restart. This happens while the 512 bit SSL parameters generation is still running. It triggers a 1024 bit generation, followed by a reload and the start of a 2048 bit generation in the background.

There seems to be a difficult-to-reproduce situation during all this, that leads to the Dovecot-server not running at all.
The joinscript later does only a reload, which leads to nothing.

This situation must be avoided, especially in appliances. A possible solution would be to add a "invoke-rc.d dovecot restart" to the end of the join script.
Comment 4 Felix Botner univentionstaff 2016-09-01 10:39:44 CEST
Yep, i added 

 service dovecot stop
 service dovecot start

to the s4/slave job cfg before the start of ucs-test. Now all mail tests succeeded. 

+1 add dovecot restart to univention-mail-dovecot join script
Comment 5 Daniel Tröder univentionstaff 2016-09-08 14:26:25 CEST
r72435: Dovecot is restarted at the end of the join script (+ merge to 4.2)
r72436: advisory build# update
Comment 6 Felix Botner univentionstaff 2016-09-12 16:34:32 CEST
OK - app test successful 
OK - univention-mail-dovecot, dovecot restart in join script
OK - yaml (small fix, r72522 univention-mail-dovecot.yaml)
Comment 7 Janek Walkenhorst univentionstaff 2016-09-14 15:39:02 CEST
<http://errata.software-univention.de/ucs/4.1/263.html>