Bug 42059 - joining a system with higher UCS version than DC Master fails
joining a system with higher UCS version than DC Master fails
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Setup wizard
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Johannes Keiser
Florian Best
:
: 45017 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-19 10:53 CEST by Florian Best
Modified: 2017-11-22 16:30 CET (History)
0 users

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.137
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017071321000419, 2017082621000134, 2017092621000276, 2017110421000277, 2017111321000616, 2017021221000082, 2017041021000493, 2017040621000321, 2017021221000082, 2017032521000305, 2017032221000605
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-08-19 10:53:01 CEST
We received the following feedback, UCS 4.1-3 errata234 (Vahr):

Domäneneinrichtung (Dies kann einige Zeit dauern): Warning: UCS version on ****.de is lower (4.12) than local version (4.13). This constellation is not supported.

We should check this prior to starting the setup wizard and disabled the join checkbox and show instead a notification/warning that joining is not possible.
Comment 1 Florian Best univentionstaff 2017-02-23 11:34:05 CET
Reported again, 4.2-0 errata0 (Lesum)

Domäneneinrichtung (Dies kann einige Zeit dauern): Warning: UCS version on PDC.*.intern is lower (4.14) than local version (4.20). This constellation is not supported.

Role: memberserver
Comment 2 Florian Best univentionstaff 2017-04-18 12:16:10 CEST
Version: 4.2-0 errata0 (Lesum)

Remark: Warum ist NIRGENDWO (!?) ersichtlich, welche Version man herunterlädt oder installiert?

Role: domaincontroller_slave
Comment 3 Florian Best univentionstaff 2017-04-18 16:37:52 CEST
Version: 4.2-0 errata0 (Lesum)
Comment 4 Florian Best univentionstaff 2017-04-21 11:54:01 CEST
Reported again, 4.2-0 errata0 (Lesum)
Comment 5 Florian Best univentionstaff 2017-04-21 15:04:08 CEST
Version: 4.1-4 errata408 (Vahr)
Remark: FYI
Comment 6 Florian Best univentionstaff 2017-04-21 15:09:48 CEST
Version: 4.1-4 errata407 (Vahr)

Domain setup (this might take a while): Warning: UCS version on mailserver.druber.com is lower () than local version (). This constellation is not supported.
Comment 7 Johannes Keiser univentionstaff 2017-11-15 17:02:42 CET
*** Bug 45017 has been marked as a duplicate of this bug. ***
Comment 8 Johannes Keiser univentionstaff 2017-11-15 17:03:32 CET
Reported again, 4.2-2 errata219 (Lesum)
Comment 9 Johannes Keiser univentionstaff 2017-11-16 13:08:04 CET
univention-system-setup (10.0.10-48)

6556db8 Bug #42059: Throw UMC Error if trying to join in dc master with lower UCS version
9dd3160 Bug #42059: Add translations
f1a3d48 Bug #45029: Debian changelog and YAML entries
ff13f1e Bug #42059: Merge branch 'jkeiser/bug_42059__join_dc_master_with_higher_version' into 4.2-2

YAML: 95b6d43 Bug #42059: YAML
Comment 10 Johannes Keiser univentionstaff 2017-11-16 18:47:03 CET
3cfee2b Bug #42059: Add error handling
ac8e6f0 Bug #42059: Merge branch 'jkeiser/bug_42059__join_dc_master_with_higher_version' into 4.2-2

80b2a67 Bug #42059: YAML - version
Comment 11 Florian Best univentionstaff 2017-11-20 14:40:17 CET
OK: an error pop up is shown if the DC Master has a lower version than the system to be installed.
OK: YAML
Comment 12 Arvid Requate univentionstaff 2017-11-22 16:30:24 CET
<http://errata.software-univention.de/ucs/4.2/227.html>