Bug 42177 - DHCP Pools cannot be created via the UMC DHCP module
DHCP Pools cannot be created via the UMC DHCP module
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - DHCP
UCS 4.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1-3-errata
Assigned To: Florian Best
Philipp Hahn
:
: 24596 26131 29510 30837 33205 36384 36918 (view as bug list)
Depends on: 24596 40649
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-30 11:10 CEST by Nico Stöckigt
Modified: 2016-11-03 11:32 CET (History)
9 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.137
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2016083021000253
Bug group (optional):
Max CVSS v3 score:


Attachments
script to create all DHCP objects (2.78 KB, text/plain)
2016-10-14 10:45 CEST, Florian Best
Details
Screenshot DHCP tree structure (20.67 KB, image/png)
2016-10-14 10:48 CEST, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Stöckigt univentionstaff 2016-08-30 11:10:24 CEST
+++ This bug was initially created as a clone of Bug #24596 +++

DHCP-Pools können nur über die Navigation angelegt werden, nicht über den DHCP-Wizard. DHCP-Pools können nur unterhalb eines DHCP-Subnetzes angelegt werden, der Wizard erlaubt aber nicht die Auswahl eines Subnetzes als "Übergeordnetes Objekt"

(Das gilt auch schon für UCS 2.4)

---

DHCP Pools are a sub object of DHCP Subnet but only DHCP Service is displayed at the left side (tree view). It's necessary to also show DHCP Subnets in the tree view to be able to add a DHCP Pool to a DHCP Subnet within the DHCP module.

Currently it's only possible to add DHCP Pools via the LDAP module, which is a bit confusing.
Comment 1 Nico Stöckigt univentionstaff 2016-08-30 11:11:19 CEST
this is relevant for Ticket#2016083021000253
Comment 2 Florian Best univentionstaff 2016-10-11 17:28:10 CEST
*** Bug 24596 has been marked as a duplicate of this bug. ***
Comment 3 Florian Best univentionstaff 2016-10-11 17:28:36 CEST
*** Bug 36384 has been marked as a duplicate of this bug. ***
Comment 4 Florian Best univentionstaff 2016-10-11 18:07:12 CEST
*** Bug 30837 has been marked as a duplicate of this bug. ***
Comment 5 Florian Best univentionstaff 2016-10-11 18:07:38 CEST
*** Bug 26131 has been marked as a duplicate of this bug. ***
Comment 6 Florian Best univentionstaff 2016-10-11 18:48:54 CEST
*** Bug 33205 has been marked as a duplicate of this bug. ***
Comment 7 Florian Best univentionstaff 2016-10-13 12:50:57 CEST
*** Bug 29510 has been marked as a duplicate of this bug. ***
Comment 8 Florian Best univentionstaff 2016-10-13 14:05:41 CEST
(In reply to Florian Best from comment #2)
> *** Bug 24596 has been marked as a duplicate of this bug. ***
→ regular duplicate

(In reply to Florian Best from comment #3)
> *** Bug 36384 has been marked as a duplicate of this bug. ***
→ This bug is very unconcrete about the Tree-View, pool-creation and general DHCP usabiltiy. This bug enhances all issues.

(In reply to Florian Best from comment #4)
> *** Bug 30837 has been marked as a duplicate of this bug. ***
This bug addresses a traceback which happens when there are regular containers underneath of DHCP services. This is fixed along as a side effect of this bug.

(In reply to Florian Best from comment #5)
> *** Bug 26131 has been marked as a duplicate of this bug. ***
This is partly a duplicate of this bug and partly a duplicate of Bug #40649.

(In reply to Florian Best from comment #6)
> *** Bug 33205 has been marked as a duplicate of this bug. ***
This is about the DHCP tree view which only has a flatten 2-D list of services and subnets AND about the grid-view which contained also non-direct-childs. With this bug this changed to be a recursive tree and only the direct childs are shown.

(In reply to Florian Best from comment #7)
> *** Bug 29510 has been marked as a duplicate of this bug. ***
→ regular duplicate
Comment 9 Florian Best univentionstaff 2016-10-13 14:10:37 CEST
This bug is blocked by Bug #40649 otherwise current environments will run into errors/tracebacks when using the DHCP module with DHCP pools underneath of shared-subnets.
Comment 10 Florian Best univentionstaff 2016-10-13 18:33:25 CEST
univention-management-console-module-udm (6.0.11-26):
r73181 | YAML Bug #40649 Bug #42177
r73180 | Bug #42177: Bug #39144: fix race conditions in superordinate handling
r73179 | Bug #42177: Bug #39144: Make it possible to select container underneath of superordinates
r73178 | Bug #42177: Bug #33205: only show direct children of the currently selected superordinate
r73177 | Bug #42177: display the list of superordinates depending on the currently selected container/superordinate
r73175 | Bug #42177: adjust Tree view

univention-management-console-module-udm.yaml:
r73181 | YAML Bug #40649 Bug #42177

univention-directory-manager-modules (11.0.3-36):
r73181 | YAML Bug #40649 Bug #42177
r73176 | Bug #40649: Bug #26131: Bug #42177: Allow DHCP pools underneath of dhcp/sharedsubnet's
r73175 | Bug #42177: adjust Tree view

univention-directory-manager-modules.yaml:
r73181 | YAML Bug #40649 Bug #42177

Merge to UCS 4.2:
univention-management-console-module-udm (7.0.1-10):
r73182 | Changelog Bug #40649 Bug #42177
r73168 | Bug #42177: Bug #39144: fix race conditions in superordinate handling
r73167 | Bug #42177: Bug #39144: Make it possible to select container underneath of superordinates
r73166 | Bug #42177: Bug #33205: only show direct children of the currently selected superordinate
r73165 | Bug #42177: display the list of superordinates depending on the currently selected container/superordinate
r73163 | Bug #42177: adjust Tree view

univention-directory-manager-modules (12.0.4-2):
r73182 | Changelog Bug #40649 Bug #42177
r73164 | Bug #40649: Bug #26131: Bug #42177: Allow DHCP pools underneath of dhcp/sharedsubnet's
r73163 | Bug #42177: adjust Tree view
Comment 11 Florian Best univentionstaff 2016-10-14 10:39:47 CEST
The "Type" column is not shown anymore in the DHCP grid.
Comment 12 Florian Best univentionstaff 2016-10-14 10:45:55 CEST
Created attachment 8100 [details]
script to create all DHCP objects
Comment 13 Florian Best univentionstaff 2016-10-14 10:48:40 CEST
Created attachment 8101 [details]
Screenshot DHCP tree structure

(In reply to Florian Best from comment #12)
> Created attachment 8100 [details]
> script to create all DHCP objects
The script creates the tree structure seen in the screenshot. It contains every DHCP objects under every possible position (including subcontainers).
Comment 14 Florian Best univentionstaff 2016-10-18 18:56:05 CEST
Fixed the javascript regression in:

univention-management-console-module-udm (6.0.11-27):
r73349 | Bug #42177: fixup svn r73168
Comment 15 Jürn Brodersen univentionstaff 2016-10-21 11:30:16 CEST
For UCS4.2
univention-management-console-module-udm: 7.0.1-12A~4.2.0.201610211117
Comment 16 Florian Best univentionstaff 2016-10-21 13:38:04 CEST
*** Bug 36918 has been marked as a duplicate of this bug. ***
Comment 17 Florian Best univentionstaff 2016-10-24 15:41:34 CEST
I added some long description for the DHCP pool as it's now creatable via the DHCP module :)

univention-directory-manager-modules (11.0.3-42):
r73502 | Bug #42177: add long_description for dhcp/pool
Comment 18 Philipp Hahn univentionstaff 2016-11-01 11:18:15 CET
OK: Creating a new object below cn=dhcp,$ldap_base shows 'server', 'subnet', 'shared network' and 'host'
FAIL: Creating a new object below *,cn=dhcp,$ldap_base shows all DHCP types in UMC - should only show pool

>POST /univention-management-console/command/udm/types HTTP/1.1
>Content-Length: 117
>X-Requested-With: XMLHttpRequest
>Accept-Language: en-US
>User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like >Gecko) Chrome/53.0.2785.143 Safari/537.36
>Content-Type: application/json
>Accept: */*
>Accept-Encoding: gzip, deflate
>
>{"options":{"superordinate":"cn=192.0.2.0,cn=phahn.qa,cn=dhcp,dc=phahn,dc=qa","container":null},"flavor":"dhcp/dhcp"}

<HTTP/1.1 200 OK
<Date: Tue, 01 Nov 2016 10:14:18 GMT
<Server: CherryPy/3.2.2
<Content-Length: 88
<Content-Type: application/json
<Keep-Alive: timeout=5, max=99
<Connection: Keep-Alive
<
<{"status": 200, "message": null, "result": [{"id": "dhcp/pool", "label": "DHCP: Pool"}]}
Comment 19 Florian Best univentionstaff 2016-11-01 13:00:26 CET
Package: univention-management-console-module-udm
Version: 6.0.11-28.665.201611011259
Branch: ucs_4.1-0
Scope: errata4.1-3

univention-management-console-module-udm (6.0.11-28):
r73966 | Bug #42177: get the possible superordinates of the current object type not of the ones for the current module flavor
r73965 | Bug #42177: get the possible superordinates of the current object type not of the ones for the current module flavor

univention-management-console-module-udm (7.0.1-13):
r73964 | Bug #42177: get the possible superordinates of the current object type not of the ones for the current module flavor
Comment 20 Philipp Hahn univentionstaff 2016-11-02 14:31:48 CET
OK: aptitude install '?source-package(univention-management-console-module-udm)~i'
OK: create DHCP pools with UMC
OK: create DHCP pools with CLI
OK: create DHCP entries using LDAP navigation
OK: test DHCP pools with client
OK: jenkins

OK: univention-management-console-module-udm.yaml
OK: errata-announce -V --only univention-management-console-module-udm.yaml
OK: aptitude search --disable-columns -F '%p      %V      %v' '?or(?source-package(univention-management-console-module-udm),?source-package(univention-directory-manager-modules))~i'
 python-univention-directory-manager     11.0.3-43.1437.201611020126     11.0.3-43.1437.201611020126                 
 python-univention-directory-manager-cli 11.0.3-43.1437.201611020126     11.0.3-43.1437.201611020126
 univention-directory-manager-tools      11.0.3-43.1437.201611020126     11.0.3-43.1437.201611020126
 univention-management-console-module-udm        6.0.11-31.668.201611020124      6.0.11-31.668.201611020124