Bug 42266 - Adjust design and functioning of 4.2 UMC module headers
Adjust design and functioning of 4.2 UMC module headers
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2
Assigned To: Alexander Kläser
Florian Best
: interim-1
: 38577 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-05 18:04 CEST by Alexander Kläser
Modified: 2017-04-04 18:28 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2016-09-05 18:04:26 CEST
The design and functioning of the UMC module headers will change with UCS 4.2.

Screenshots can be found at:
https://mail.univention.de/appsuite/#!&app=io.ox/files&folder=1206&id=1206/1396
Comment 1 Florian Best univentionstaff 2016-09-13 13:49:44 CEST
*** Bug 38577 has been marked as a duplicate of this bug. ***
Comment 2 Florian Best univentionstaff 2017-02-15 15:33:19 CET
The "disabled" flag for menu entries is not evaluated. (E.g. the currently selected language in the menu should be disabled while it is not).
Comment 3 Alexander Kläser univentionstaff 2017-02-21 09:23:42 CET
(In reply to Florian Best from comment #2)
> The "disabled" flag for menu entries is not evaluated. (E.g. the currently
> selected language in the menu should be disabled while it is not).

→ I noted this at Bug 43528, comment 15.

Otherwise the module headers are working as they should.

univention-management-console (9.0.35-1):
r76866 | Bug #42266: adjust module header styling + clear module description
r76340 | Bug #42266: remove CSS rule for colored module header

univention-web (1.0.26-5):
r76866 | Bug #42266: adjust module header styling + clear module description
r76341 | Bug #42266: adjust styling of modules headers

changelog-4.2-0.xml:
r76893 | Bug #42266: added changelog entry
Comment 4 Florian Best univentionstaff 2017-03-08 17:11:26 CET
OK: header buttons
OK: changelog
Comment 5 Stefan Gohmann univentionstaff 2017-04-04 18:28:53 CEST
UCS 4.2 has been released:
 https://docs.software-univention.de/release-notes-4.2-0-en.html
 https://docs.software-univention.de/release-notes-4.2-0-de.html

If this error occurs again, please use "Clone This Bug".