Bug 42443 - Student won't be added to school groups of second school if created with two schools
Student won't be added to school groups of second school if created with two ...
Status: RESOLVED DUPLICATE of bug 40870
Product: UCS@school
Classification: Unclassified
Component: Ucsschool-lib
UCS@school 4.1 R2
Other Linux
: P5 normal (vote)
: ---
Assigned To: Bugzilla Mailingliste
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-20 13:52 CEST by Michel Smidt
Modified: 2016-09-21 09:41 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Smidt univentionstaff 2016-09-20 13:52:19 CEST
appcenter/apps/ucsschool/version: 4.1 R2 v4

First created two schools in UMC.

root@dc:~# python
Python 2.7.3 (default, Aug 29 2016, 16:34:01) 
[GCC 4.7.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from ucsschool.lib.models import Student
>>> from univention.admin import uldap
>>> connection, position = uldap.getAdminConnection()
>>> student1 = Student(school="Schule1", schools=["Schule1", "Schule2"], name="student1", lastname="Student1lastname", firstname="Student1firstname")
>>> student1.create(lo=connection)
True
>>> udm_student1 = student1.get_udm_object(lo=connection)
>>> print udm_student1['groups']
['cn=schueler-schule1,cn=groups,ou=Schule1,dc=prog,dc=int', 'cn=Domain Users Schule1,cn=groups,ou=Schule1,dc=prog,dc=int']

<- Not OK

I would expect that student1 is also member of "schueler-schule2" and "Domain Users Schule2".
Comment 1 Daniel Tröder univentionstaff 2016-09-21 09:41:01 CEST
Already fixed in errata scope. Not sure in which bug though.

*** This bug has been marked as a duplicate of bug 40870 ***